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Chapter 1

General Information

1.1 About this Book

This documentation serves as a reference of the Cenon functions. One chapter de-
scribes in short how to work with Cenon by example. This alone makes the book
thick enough. Additional dokumentation for the modules and special tutorials for the
different applications of Cenon are planned.

This book describes the Astrology module for Cenon. It is meant as a reference as
well as a working book. A description of Cenon in general can be found in the Cenon
User’s Guide.

Depending on your computer system (Linux, Apple) or the applied Theme (skin),
there are differences in the look of the user interface. The panels depicted in this book
may differ in their look from the interface you are using, although the placement of
the controls remain identical.

The various computer systems (Apple, Linux, OpenStep) also show some differences
in the directory structure. This information is always given for all systems.

This book has been written using LyX. The title page and the slip case were designed
with Cenon.
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All trade marks like PostScript, Adobe Illustrator, HPGL, DXF, Gerber, Excellon,
Sieb&Meyer etc. belong to the respective owners.

1.2 The history of Cenon

Cenon has been started in late 1992 / early 1993 as a
production software under NextStep/OpenStep. Since then, Cenon has made lots of
friends all over the world and is still making more.

Besides the usual improvements of a software project, the features of OpenEnd (Vec-
tor graphics conversion), and CenonPCB (prototyping of printed circuit boards) were
merged into Cenon. Additionally basic font editor functions were added from a
started project.

In the year 2002, Cenon was completely redesigned with a modular concept. This
makes Cenon expandable by modules for extremely different graphical applications.
The first modules available are a CAM module and an Astrology module. Two ap-
plications from opposite sides of the spectrum.

From 2000 on, Cenon was ported to GNUstep (Linux & Co) as well as the new Apple
operating system (Mac-OS X). In addition, most other Unix systems are supported.

During the conversion of Cenon into a modular software, we also included the Astro
program, which has been started in 1998 for research into Astro-Resonance, and
turned it into a beautiful Cenon module.
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The whole basis of Cenon with its vast set of features, including vector graphics
conversion, vector design, publishing etc. is available as Free Software since 2003.
The manufacturing software Cenon CAM is available as a commercial application.

In 2012 Cenon reached version number 4.0 with many improvements like SVG im-
port.

1.3 What can you do with Cenon ?

Cenon is a modular graphical software. In it’s basic version Cenon is most at home
in the area of Vector-Graphics Design and Desktop Publishing (DTP). The idea of
Cenon is a merger of vector design and publishing, an easy and straight forward tool.

With the powerful import functions of Cenon, you can import and edit almost all
graphics formats (PostScript, HPGL, DXF, SVG, ...). The design functions fulfill all
common Publishing demands. The output possibilities mirror the import capabilities
and aim to give productivity to the user with as much flexibility as possible.

Moduls for Cenon can provide additional functionality. The first module for Cenon
was the CAM module. This module turns Cenon into what it was from the begin-
ning - a production software for manufacturing on CNC-machines like engraving
machines, milling machines, routers, tool-plotters, cutting-plotters, and pen-plotters.
Cenon CAM is a universal production software and has its application in the indus-
trial area as well as in sign-making, or model-making.

This user guide for Cenon describes the Cenon Core. For a description of the modules
and special Cenon-Packages, please refer to the corresponding document.

1.3.1 Cenon

Key Features

* Import of SVG, PostScript, PDF, Adobe Illustrator (AI3), DXF, HPGL, Gerber,
Excellon, Sieb&Meyer, Type 1 fonts, ...
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e Import of scanned images (TIFF, PNG, GIF, JPG ...)

» complete set of editing functions for lines, curves, arcs, complex paths, poly-
lines, text, threads, countersinks, etc.

» comfortable management of layers and pages

* DTP functions like clipping of images and color separation

e Text along paths

* Color shading (graduate, radial and axial)

* Color-Separation, Crop-Marks (Pre-Printing)

* vectorisation of raster images

* Rich Text (vector fonts (Type 1, TTF), tabulators, rotation, ...)
* Easy and intuitive operating for fast and accurate working

* Batch processing

* Export of PostScript (PS, EPS), HPGL, DIN, Gerber (RS274X) and more
* Font editing of Type-1 fonts (not very comfortable yet)

* Extensible via additional modules (Plug-Ins)

Examples of applications

* Desktop Publishing (DTP) - Creation of Book-Cases, Stationary, Logos, Ad-
vertisings, Banners, ...

e Multi Page Documents like Brochures, Flyers, Booklets, ...

* Mousepads, Business-cards, Bookmarks, CD-labels, ...
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* Letters and Forms of all kinds with predefined text masks

* Vector Graphic Conversion, including postprocessing of all import and export
formats in every direction.

¢ many many more

1.4 The world around Cenon

This chapter displays a few services and products around Cenon. You will find more
on the Cenon web pages.
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1.4.1 Folder and printed book

You can order the Cenon Slip-Case including Manual and CD in our Online-Store:
http://www.cenon.info

1.4.2 Modules for Cenon

Cenon ist a modular graphics application. With the aid of modules Cenon can be
extended in functionality, or transformed into a very special application. Usually
modules are bundled with Cenon as complete Application-Packages. Examples for
specialized Application-Packages are


http://www.cenon.info
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Cenon CAM (http://www.cenon.biz)
Cenon Astro (http://www.cenon.info/astro).

1.5 Installation

The installation process for Apple and Linux differ slightly. Please read the section
of your System.

Here we describe the installation of the executable packages only. If you want (or
need) to compile Cenon yourself, take a look at the file INSTALL inside the source

tree.

1.5.1 Installation on Apple (Mac OS X)

1.

Insert the Cenon-CD and wait until the CD-Symbol appears in the Finder.
Then click on the CD-Symbol and select the path of Cenon for Apple (Apple >
Packages). If you downloaded Cenon, you have to unarchive the downloaded
file instead (double click).

. You will find a package with the name Cenon-x.x.x.pkg, where x stands for the

version number. Double click the package to start the installation.

. The installer appears, where you have to authorize yourself as administrator.

. Next you can start the installation process by confirming the different stages

(Introduction, Read Me etc.). The files are now extracted from the package and
copied to your hard disk. This takes a few moments.

. If you have a previous version of Cenon already installed, the installation pro-

gram will tell you. Just continue the installation.

After the package is installed, you can start Cenon. To do this, go to the direc-
tory ’/Applications’ and start Cenon with a double click.


http://www.cenon.biz
http://www.cenon.info/astro
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If you are installing the CAM version of Cenon, please refer to the CAM man-
ual for further installation.

. To be able to import PostScript or PDF files, you have to install GhostScript.

You can get a version of GhostScript from the same place where you got
Cenon, but any other version of GhostScript will do the job. Double click
on the GhostScript package to start the installation.

1.5.2 Installation on Linux

1. log in as user root

2. Insert the Cenon-CD and mount the CD. Then change to the directory of Cenon

for Linux (Linux > Packages). If you downloaded Cenon, you can skip this
step.

. You will find a RPM package. Install it with the installation tool of your Linux

distribution, or enter the following command in a terminal shell:

rpm -Uhv Cenon.rpm

. To start Cenon go to the folder /usr/GNUstep/Local/Applications and start

Cenon with a double click. If you don’t habe GWorkspace running you can
start Cenon by typing 'openapp Cenon’ from a shell.

If you are using the CAM version of Cenon and it is your first installation,
Cenon will ask you for a license key.

1.5.3 Installation on OpenStep (Deprecated)

1. Log in as user root

2. Insert the Cenon-CD and wait until the CD-Symbol appears in the File Viewer.

Then click on the CD-Symbol and select the path of Cenon for OpenStep
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(OpenStep > Packages). If you downloaded Cenon, you have to unarchive the
downloaded file instead (usually a double click should work).

3. You will find two packages, which you have to double click one after the other.
The names are:

(a) Cenon.pkg
(b) CenonLibrary.pkg

4. For each package a window will appear, where you have to click on Install.

5. Then another window appears. Just click on Install or press Enter. The files
are now extracted from the file and copied to the hard disk. This takes a few
moments.

If you have an old version of Cenon already installed the install programm will
notify you. Just continue the installation.

6. Wait until the first package has been finished before installing the next one.

7. After all packages are installed start Cenon as user root. To do this, go to the
directory */Local Apps’ and start Cenon.app with a double click.

If you have installed the CAM version of Cenon for the first time, the license
panel appears. Here you can license the program (See the next section) or
decide to run it in demo mode.

1.6 Initial Operation

You will find Cenon in the application folder. Double click on the Cenon.app to start
Cenon.

To get the Cenon-Icon into the dock, you can simply drag the Icon from the applica-
tion folder and drop it on the dock.
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Now, you can start Cenon, by clicking the Cenon-dragon in the dock.

In the library folder of Cenon you will find some examples: The folder 'Projects’
contains some example Cenon projects. The folder "Jobs’ provides CAM examples,
and the folder 'Examples’ provides examples of import formats.

The library of Cenon resides in slightly different places, depending on your system:
Apple: /Library/Application Support/Cenon
Linux/GNUstep: /usr/GNUstep/Local/Library/Cenon

OpenStep: /LocalLibrary/Cenon

1.7 Updates

Cenon can inform you automatically about available Updates. About once a week
when Cenon is started, Cenon will check with the Server, if a new release is available.

You can manually check for updates via the menu Help > Updates.

If a new release of Cenon is available, the Update-Panel appears.
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Check for Updates

A new version of Cenon is available

Cenon 4.0.0 is now available - you are running Version 4.0.0. Would
you like to update?

Size

164 MB

Cenon CAM 4.0.0 - Manufacturing with Style
2012-06-12 E]

Version 4.0.0

+ New: SV G-Import (Scalable Vector Graphics)
Millions of vector data are readily available on the Internet, Signs, Logos,
Crests, Symbals, lcons and more are waiting for download and manufacturing.
After often just a few tweaks with Cenon, the graphics is ready for machining.
+ New: Embedded CNC-Commands
Text starting with #COMMAND_BEG#" or "#COMMAND_END#" will be

interpreted as direct CNC command. The rest of the string goes as is to the s
machine. hd
( Skip this Version _-:1 f_ Close ) (_ Download :1
o

Cenon will check for Updates of your Cenon-Flavour and installed modules. Cenon
will display the corresponding Packages in a list, including Package Name, Version,
and File Size.

If you click on an entry in the list, the description of improvements of this package
will be displayed.

Skip this Release once clicked, you will not be informed about this specific
version automatically. You can still use the Menu Help >
Updates to manually check for this version.

Close the Update-Panel will be closed without action.

Download all packages, which are checked, will be downloaded to
your Download folder. Cenon will open the installer for
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you, however (for now) will not install the packages au-
tomatically.

Automatic update checks can be disabled. To do so, you have to go to the Cenon
Preferences (see section 3.1) and activate the switch ”Disable automatic check for
Updates”. You can still check for updates manually via the menu Help > Check for
Updates or via the Cenon Web-Site.

1.8 Support

User Guide

WWW

Mailing list

eMail

Bugs

We try to keep the user guide practical and full of information. The user
guide should answer most of your question.

You can find information about new versions and an up-to-date FAQ
(frequently asked questions) on our Website:
http://www.Cenon.info.

In the mailing list of Cenon, you can ask questions and exchange your-
self with other users of Cenon. To subscribe to the mailing list you can
go to the Support page of the Cenon internet site.

Direct support for the free software is only offered via e-mail.

Since Cenon is free software we can not gurantee for answers. Please
try to check out other possibilities (User guide, FAQ, mailing list) be-
fore asking for e-mail support.

If you find a bug, we are thankful to receive your bug-report or even
better a patch. We will try to fix serious bugs for the next release.


http://www.Cenon.info
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1.9 The file-extension and icons

Icon for the Cenon-project. The file extension is: .cenon, (.cen)

Extension and icons of import-formats

im Icon for HPGL-files. The recognized extensions are: .hgl, .hpgl, .plt

A Icon for DXF-files. The extension is: . dxf

u@ Icon for Adobe Illustrator files. The extension is: .ai

This is the icon for PostScript files. The look of the icon might differ
somewhat from system to system. The possible extensions are: .eps, .ps

This is the icon for PDF-files. The look of the icon might differ some-
what from system to system. The extension is: .pdf

Gerher

This is the icon for Gerber-files. The possible extensions are: .gerber,
.ger
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This is the icon for Scalable Vector Graphics (SVG)-files. The possible
extensions are: .Svg

The icon for DIN-files like Excellon or Sieb&Meyer. The possible ex-
tensions are: .din, .drl
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Publishing with Cenon

In this chapter we use the example of a cover page to describe all the steps necessary
to create a Cenon document. Although we use a publishing example here, everything
applies equally to other applications of Cenon. The other chapters of this book serve
as reference of the Cenon functions. For further special description and examples of
how to use Cenon, we refer to the other Cenon documents.

The general proceedings when creating a Cenon document is as follows.

1. Creating a new document; Import of a Graphic; Loading an existing project
mask

2. Creating of new layers for the separate working steps
3. Editing of the project (document)

4. Export and Output

To get a mental picture of our work before starting - as every artist has, we now take
a short look at the final result. That’s how our document will look like, when we are
through this tutorial:

23
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2.1 Create a new Document

2.1.1 Preparations

Before we start, we can set some preferences.

Import

General
S an Disable Caching ¥
O off Genon Expert W]
() 2 Pixel Remove Backups W
4 Pieel Selection of non editable layers [ |
O 8 Puxel Select Objects at border only [ |
Unit Disable Anti Aliasing [ |

@ Save ASCII (readable, compatible to OpenStep) |

Line Width (pt): O

You can reach the Preferences Panel by the menu Info > Preferences.

Here you can choose the unit of measurement (mm, Zoll, Point). We select mm for
our example.

Additionally it seems useful for DTP applications to disable the selection of non
editable layers.

Important for our work is to set the snap-to-point distance. 2 pixel should be well.

Further information on the preferences can be find in section 3.1.
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2.1.2 New Document

In the menu Document with the menu entry New (Cmd-n), you can create a new
Cenon document. What we get is an empty document window with the title "Unti-
tled".

0686 ] UNTITLED1
| X: 190.7306 Y: 12.9306 Width: 200.7306 Height: 22.8306 mm | ;| E‘Jx_, 100%: o] * |
=]
Pl 0
WL .i
b

T I
The crosshairs don’t have use for us at this place. We simply move them to the lower
left corner of the window, so that we get the coordinates 0/0 displayed for them inside
the Inspector Panel.

The crosshairs are the origin of our coordinates. They can be moved to any desired
position from where the coordinates should be measured or the grid should start.

2.1.3 Set working area

As we want to print our cover page on a DIN-A4 paper, we set the working area of
the document window to this format. To do this, we open the Working Area Panel
via the menu Format> Working Area or by using the keyboard shortcut Cmd-A.
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Width [mm]: | 209.8028

Height [mm]: 287.0389

The format A4 has a width of 209 mm and a height of 296.86 mm. We simply enter
these values into the text fields and press Enter on our keyboard.

2.1.4 Save Document

To have the document created permanently, we save it to a file and give the file the
desired name. Cenon documents on disk get the extension ’.cenon’. That’s how they
are identified.

To save the document we open the save panel via the menu Document > Save (key-
board shortcut: Cmd-s)
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Save As: Cover.cenon

o

CIRNE

= ) | GapTP

i @

» DEVICES

» SHARED

> PLACES

¥ SEARCH FOR
(L) Yesterday
(L) Past Week

|1 Today

| 7w Astro

M cam

[ Devices

[ Documentation

[ Examples

[ Met
[ Projects
4[] Resonator

_'“

v ¥ 5

vy ¥ ¥

|
l

=l |

T S T T T TR T TR T

Chinese.cenon

[:] Clients
1 Clipart

DamelmBoot.cenon

., Ducks.cenon
] Examples

M adice
E—-

Ad
Ad'

£ Cal

W vhif

Farmat

[ Cenon [.cenon)

New Folder

{Cancelj ( Save }

]

Here we can go to the desired folder and provide the filename inside the text field
called Name. We call our document CoverCAM.cenon. By pressing OK, the docu-
ment will be saved.

2.1.5 Grid

To make the positioning of our graphic objects easier, we can activate a background
grid. All graphic objects will then snap to this grid.
To create the grid, we have to open the Grid Panel via the menu Format > Grid or the
keyboard shortcut Cmd-*.
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First, we better choose the same measurement unit like our coordinates - mm. This
avoids confusion. Then we enter the grid distance into the text field. In the example
we use a grid distance of 5 mm. By pressing the Set button, the grid will be created
and displayed with gray lines.

To activate and deactivate the grid during work, we can now simply use the key
Cmd-+ or the menu Format> Grid.

2.2 Create Layers

To have a better overview and more flexibility we can organize our graphic elements
on several layers. For example, we can place large background objects of our docu-
ment on their own layer. To focus on other objects we can now simply disable this
layer.
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ONOLC irs 0.1 0 Path
+OlE | +E LOE | +E
&  Background &  Background
& / Cenon & 7 Cenon
#& 7 UNTITLED == g= Text Deutsch
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To create a new layer, we need the layer inspector. We get it from the menu 7ools
using the menu entry /nspector, and then inside the Inspector, clicking on the right-
most icon in the top icon bar. Alternatively, we can simply use the keyboard shortcut
Cmd-5. To have this work, our graphic window has to be in the foreground!

A new layer will be created with the button New. The layer appears with the name
UNTITLED and has to be renamed to the desired name. The layer will be placed to
the lowest position in the layer list. You can move it to any position inside the list
with the mouse (while pressing the Control-Key on your keyboard).

We create the following layers for our document:

Background A layer for the background elements. A layer like this makes sense,
so we can’t accidentally select the background while editing in a high
zoom, probably without even realizing. We now simply turn the layer
not editable to avoid this problem.
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Cenon Here we place the main elements of our cover page. Those which are
not language dependant.

Text Deutsch This is our layer for German Text.

Text English Here we place the English version of our text. This way we can man-
age all desired languages without efforts in one single document.

Images This is the layer for our images. An extra layer for images allows
editing without bothering about other graphic objects.

Help Help lines and guides are placed here. This layer will be disabled for
printing as it only serves to simplify our work.

Further information about the layer inspector can be found in section 3.6.19.

2.3 Get to business - the Design

2.3.1 Help layer

On the help layer we place supporting details, which we don’t need afterwards on
our print. Beside help lines (guides), these could be things which show our cover
page as it would appear as complete handbook. As the background of the book will
be filled over size, we also draw a frame which shows the real end size of the cover

page.

& 7 First, we turn on the help layer, and turn off all other layers. This can be
achieved simply by clicking on the eyes inside the layer inspector. An open eye
displays the layer. To be able to edit objects on the layer, the pencil has to be intact.
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Now we create the frame of the cover page in the desired size. We select a
discreet color for the rectangle, for example gray. The origin of the frame should be
placed to even coordinate without decimals, this makes things easier.

We lock the position of the frame, so we can’t move it accidentally. This is done in
the ractangle inspector (Cmd-1) with the switch Lock.

The edges of the frame will be used, in the following design process to snap our
objects. So, they are guides too.

To give our cover page the look of a real book on screen, we draw wire rings and
punch holes. This helps visualizing the final results.

Tip: If you happened to draw on a wrong layer and now want to move the
object to the right layer, you can do the following:
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* select the object (both layers have to be visible and editable)

* choose the destination layer from the layer inspector

* click on "Move to layer" to finally move the object

2.3.2 Background

Now we start with the background. We turn on the background layer and turn off the
other layers (not visible or at least not editable). The help layer should remain visible
to allow snapping to the grid.

On this layer we place the cutting marks and other markings, which need to be
printed. If we have many markings, we could use a layer of it’s own for the markings,
of course.

Last but not least, we place our background image here. In our case a polished
aluminum surface. The image should have a sufficient height resolution. About 600
dpi should be enough. The image can be provided in almost any format.
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To get the image into our document, we have several choices. We can drag it directly
from the Workspace (or the Finder on Apple) into our document. We can import the
image via the menu Document > Import, as well.

We now scale the image to the desired size. If it is much larger than the window, we
use the Transform Panel to bring it down to a reasonable size first. We find the panel
in the menu 7ools > Transform Panel (shortcut: Cmd-F).
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In the pop up menu on top of the panel we select Scale. Now, we scale by keeping the
aspect ratio of the image (Uniform scale) to say 80% of the original size. If we have
the image completely inside our working area, we can do the rest using the mouse:

First, we grab the lower/left corner of the (deselected!) image and drag it to the outer
edge of our help frame. There the position will snap in.

In the second step, we grab the upper/right corner. This time while keeping the
Control key (Ctrl) on the keyboard pressed. Resizing the image this way, will keep
its natural aspect ratio. We snap to the corresponding edge of our frame.

If we have mastered the background, we turn the layer to non editable (broken pen-
cil).

Tip: We should save our work from time to time. Whenever a working step
is finished we could even save under a different name, this way keeping
several versions of our work.

More information on the Transform Panel can be found in section 3.8.



36 CHAPTER 2. PUBLISHING WITH CENON

2.3.3 Cenon

Now, after all the preparation, we can start the actual design of the title image. First,

we turn on the corresponding layer (we have called Cenon), so that the layer is visible
and editable.
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Triangles

We start with the two blue triangles (to be exact, our triangles have four edges). The
triangles are paths, which are composited from lines. The lines are then joined and
filled.

First, the upper triangle...
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We need the Line tool to draw the lines. We find it in the Tool Bar (menu Zools >
Tools...), and activate it with a click by the mouse.
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We draw the lines with the mouse. We first click at the start position of the line
and then at the end position of the line. If we don’t snap to another object, the next
line segment is started automatically. We draw the complete train of lines and end it
exactly where we started.

Tip: To avoid starting a new line every time we have ended a line, we can
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draw the train of lines roughly to the side of the help lines. If we have
completed the train of lines, we can easily drag the line ends with the
mouse to their exact position on the help lines.

If the lines are drawn, we leave the line mode and go back to the arrow.

To create a path from the lines, we have to select all the lines, which are part of the
deal. As we don’t have any other lines on the layer, we have easy play: We simply
select one single line and go to the menu and select Edit> Select equal (shortcut:
Cmd-e). Now, all lines are selected. To join them, we select Edit>Join from the
menu (shortcut: Cmd-j). Now, if we don’t have selected too much, we get a closed
path.

Now, even inside the path we can move the edge points of our path easily to the
desired position.

Now, we make a copy of the first path to create the second triangle. After selecting
the path, we use the keyboard and press Cmd-c followed by Cmd-v. Now we have
two triangles. If you don’t like your keyboard, you can also use the menu to copy the
path. Use Edit> Copy (Cmd-c) and Edit> Paste (Cmd-v) to do this.

We mirror the new triangle with Edit>Mirror (Cmd-m) and are almost done. We
move the whole thing with the mouse to the lower right corner of our guides. Be
aware, that before you grab the corner of the triangle, the triangle has to be deselected
(without knobs)! Then, we move the triangle to the help frame that the two corners
snap together.

Finally, we drag the upper two edges of the "triangle" to the tips of the upper "trian-
gle" - ready!
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Now we make color: To do so, we select the two triangles and select the fill button
in the Inspector (shortcut: Cmd-3). In the pop up menu we select Graduated. Now
the triangles are black, but we will manage to give them a nicer color.
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To select a color, we click on the border of the upper Color Well in the Inspector
panel. The Color Panel will open up.

We want a beautiful dark blue. Then we do the same with the lower color well and
give it a bright blue with much green, so that we get the color of a blue sky.
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To make the graduation smoother on our print out, we set the step width to a finer
level. Three pixel should do well.

Now we want to rotate the color graduation of the lower triangle. To do this, we
select the upper triangle with the mouse, while keeping the Shift-Key pressed. This
deselects the upper triangle! Then we set the Graduate Angle to 180 degree.

More information on the Fill Inspector can be found in section 3.6.17.
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To use a graphic of the complexity of the dragon, we should have a separate document
to create it in all silence. When we are ready with the design and have set all the color
shades as needed, then we grab it into our document. If not a separate document, a
separate layer would be sufficient too. But we have the dragon ready for ages now
and simply copy or import it to the place where it is needed.

We already covered the import of graphics, so now we open the dragon in a second
document, select what we need, and copy it with Cmd-c / Cmd-v into our document.
Here it is! The first time it needs some time to render the many color shadings in
the background, but from then on the rendering goes fast. What follows is a well
known procedure, scaling (Transform Panel), 90 degree rotation (Cmd-r), moving
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(for example with the mouse), mirror (Cmd-m) - and Voila.

Logo

The same thing with the Cenon logo - we copy it into our document. The internet
address (www.cenon.info) is standing in small letters below the logo. We will do this
little text by hand, now.

Text
We start by activating the text tool. With a click by the mouse at the desired

position on our document, a text box pops up at this position and wait for our input.
On top of the document window a text ruler will be displayed, which gives us pow-
erful functions for alignment, tabulators etc. We set the text of the internet address to
right alignment.
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Now we select the entire written text and open the Font Panel to set the font size.
We get the panel via the menu Format > Font> Font Panel (Cmd-t). Here we set the
desired font and size and press the Set button.
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E We leave the text mode and go back to the arrow. Then we select the newly
created text box with a single mouse click.

Within the Fill Inspector (Cmd-3) we give the text the correct color. Then we move
the text to its position under the logo.

To get the text box aligned exactly to the right of the logo, we now use the Transform
Panel. So we do the finger trick Cmd-F (or Tools > Transform Panel). In the menu at
the top of the panel we select Align.



2.3. GET TO BUSINESS - THE DESIGN

O ) O Transform.

“‘||J+u ":’|E+E| "‘

-rJ | | J-.!"" ,_- -y ‘J

Align

Horiconital
EEE

Vertical

5t (o

] Align Layers

45

The graphic objects which we want to align must be selected. As the logo already
sits at its place, we only want to align the text in relation to the logo. So we first
select the logo! Then we select the text while keeping the Shift-Key pressed. Doing
this we ensure that the logo will not be moved, only the text. The first selected object

serves as the reference for the align function.

If we now press the right button inside the panel, the text will be aligned to fit under

the logo on the right side. Try it!

If everything fits perfectly, we group logo and text together, so they can’t escape any
more. We simply select both objects and choose Edit> Group from the menu. We

can also use the shortcut Cmd-g from the keyboard.
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2.3.4 Text

Now off to the text layers. If you remember, we have created a text layer for each
language. This way we only need one document for all languages.

We fill one text layer after the other with text. First we turn on the text layer we want
to edit (visible and editable). All the other layers should be at least not editable.
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We already know how to place text. So, select the text tool from the Tool Bar, create
a text box, write the text, set the font and the font size.

This time we don’t set the font size for the entire text box. Instead we set the font for
the selected region of the text, only. The text region can be selected with the mouse.
A whole word is selected by a double click, and a whole paragraph can be selected
with a triple click. We select the region "Version 3.60", because this text needs to be
a little smaller. We select the size for this region as usual from the Font Panel. The
line height can be adjusted using the ruler on top of the document window.

If size and line height are correct, we move the text to its position, do corrections if
needed, and we are ready with our text.

The same play follows for all the other languages we know. But, here we take the
easy way and simply copy and change the text box to the other layers. That’s a
known procedure with Cmd-c and Cmd-v. It is important here, that the destination
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layer is editable before you paste with Cmd-v and that none other layer has priority
and steals your text away.

2.3.5 Images

Now the best of all, exposing images from the background. First we turn off all
other layers - just the image layer and us. Now we can peel our machine from the
background without disturbance. Before we start, we have to drag the image into our
document and scale it to reasonable size to fit in the window.

We have the image in the document? Well, lets give it a nice name using the Inspec-
tor. We also select a format to compress the image on disk. The correct scaling of
the image doesn’t matter for now. First we have to get rid of the background.

We start by buckling up the image, so it has no chance to slip away. This can be done
in the Inspector by activating the Lock switch. We already know this button.
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Now we start placing a path exactly around our image, which resembles the contour
of our freed object.

Tip: To jump from the tools of the Tool Bar into the arrow mode without large
mouse movements, we can simply press the Alt key. As long as the key
is pressed we are in the arrow mode, able to move Objects instead of
creating them.

e,
7 We start with the straight segments of the path, which we can simply bridge
using lines. We select the line tool and on we go. If our track makes a smooth turn,
we end the line with a double click on the mouse. Then we start a new line where
further lines are needed. It is easier to draw all the lines first, and later add curves in
between. This way we don’t have to change the editing modes.
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by four clicks with the mouse. The first click sets the starting point of the curve.
We start our curves exactly at the end points of the lines, where they will snap in (to
make this work we have activated the snap to point distance in the preferences). We
set the endpoint of the curve with the second click to the starting point of the next
line - or somewhere in between. A bezier curve shouldn’t be too complicated. More
than 90 degree turns are not recommended. The remaining two clicks set the control
points of the curve.

Don’t forget the open areas inside the image.
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If all lines and curves are placed all together present a closed picture without gaps,
where everything is nicely snapped together, then we can gather all parts and create
a path. We already know how to do this from the triangles.

So, we select all lines and curves, which will be used to free the image. We then
select from the menu Edit> Join (or press Cmd-j). To select all the parts it is again
enough to select one line and one curve. With Cmd-e all the other lines and curves
will be selected, too.

Don’t forget to save from time to time. That was a good piece of work.

Now, we fill the path to see if everything fits. To do this we go to the Fill Inspector
(Cmd-3) and set the pop up to Filled. Now we see, if we have closed accurately all
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the subpaths. Are there lines intersecting all of the path, then there was a gap, and
Cenon wasn’t able to close it. In this case we have to split the path with Cmd-J and
correct the related segment connections. Then try again.

Now we do the fine tuning of the path, because we want it perfect. Our path should
go exactly along the edge of the object. So we zoom in as deep as it makes sense and
correct the line and curve points until we are satisfied.
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To move the vortices of the path, the path has to be selected. Then you can grab a
vortex and move it.

Tip: If you happen to click beside the path or the vortex, the image will be
selected. However, if you select the image once again while keeping the
Shift key pressed, you can easily deselect it again.

If a line is missing you can cut the path into two, using the cutting tool. Now
you can add the missing elements and join the parts to one (Cmd-j).
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Finally, if the path is perfect and ready, we can join it with the image. Select the path
and the image and once again use Edit> Join (or Cmd-j). The background is gone!

Lt

Now we make all the other layers visible again, move the image to its place, and
scale it down to the final size. To move the image, we have to unlock it, of course.
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4 little images

Now, only the four little images are missing, then we are through. So, lets start
by placing four rectangles, which will be used later to clip the images from their
background. Just the rectangles without the images for now.
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To place the rectangles we select the rectangle tool from the Tool Bar. The
rectangle is placed with the first click. The second click sets the size. The size can
be changed later using the inspector or the mouse, of couse.

We copy the first rectangle three times - or do we need four? This way we can
play and look without producing too much work. Does a rectangle or a square look
better? You can change the size of all rectangles together in the Inspector. Just select
all rectangles and set the size and height. Be careful with setting the origin this way,
or all your rectangles will be dumped to a pile. Not a big problem, however. Press
Undo (Cmd-z) to revert the little accident.

Now the images for the rectangles. They shouldn’t be larger as needed for the print.
Also, not needed parts of the images should be removed in a image processing tool
(for example Gimp).
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We now move the first image into our Cenon document, give it a nice name and set
the compression format.

We place the image at its position and direct it behind the rectangle, so that the
rectangle is in the foreground and not invisible behind the image. We achieve this
with the menu Format > Move to back (Cmd-9), while the image is selected. Now we
scale the image down using the mouse while keeping the control key (Ctrl) pressed,
until it sits correctly inside the rectangle. To accomplish this we grab the image at one
edge and drag this edge to the center of the image until the desired size is achieved.

Finally, if the image is in position, we select image and rectangle and join both by
pressing Cmd-j (or using the corresponding menu entry).
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With the other images, we do the same - Ready!
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2.4 Printing / Color separation

Before we start printing, we have to set the paper format for printing. So far we only
set the size of the working area. The format for printing could be different.

Use the menu Format> Page Layout (or Cmd-P) to open the Page Layout Panel. We
set the format to the same format as the working area - DIN A4. We press OK to
affirm our change. The resolution of our document, should be 100% for printing.

To finally get it printing or separate colors, we select Print from the menu (shortcut
Cmd-p). The Print Panel appears.
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Here we can select the printer (if we have more then one), set the number of pages to
print, set the scaling etc.

2.4.1 Printing

To print, we don’t have to do more than press OK.

If we want to print to file we press Save, instead. A Save Panel appears, which let
us set the directory and file name. By confirming with OK, a PostScript file with the
extension ’ps’ or a PDF file (if your systems allows this) will be written.

2.4.2 Color Separation

To separate colors, we have to set the kind of output to color separation. The color
separation can be printed or saved to file. This will create four distinct files repre-
senting the separate colors (Cyan, Magenta, Yellow, Black). The four files will get

b 2

the endings ’_c’,’_m’,’_y’,und ’_k’.

For further information on color separation take a look at section 3.15.
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Chapter 3

Reference part - the functions of
Cenon

3.1 Preferences settings

You can enter elementary preference settings for Cenon in this dialogue box. You get
there over the menu information, entry basic setting. The preferences are ordered on
several cards, which can be reached by the icons on top of the panel. The available
icons depend on the modules plugged in.

59
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3.1.1 General Preferences

General
Snap to Point ; Disable Caching E
O Off Cenon Expert E
() 2 Pixel Remove Backups ¥
(=) 4 Pixel Selection of non editable layers ||
() 8 Pixel Select Objects at border only (W]
Unit Disable Anti Aliasing [ |

' Save ASCIl (readable, compatible to OpenStep) | |
Line Width (pt): ln I

Snap to Point

() off

() 2 Pixel
(=) 4 Pixel
() 8 Pixel

Here you can choose whether the mouse is caught by existing points or not and how
big the distance should be during the editing.

The function helps a lot in precise construction work, as new or moved graphic ob-
jects snap to points of other graphic objects. You can also use this function to create
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your custom help raster (e.g. in the form of a spiral), so that the edited graphic objects
will be attracted by the nodes.

Unit

[ mm [

Here you can set the unit with which all the measures of the program that are not
specially signed are displayed. Some windows, like the graphic window, have their
own pop-up-menu to define/set the unit.

Line Width {pt): E]

You can set the default line width for Cenon. This value is used whenever you create
a new object. The line width or border will have this value.

Switches:

Disable Caching When you don’t want the graphic to be cached -
that means that a copy of the entire document is
stored in the background even when only a section
is displayed - you can switch it off here. When
you have little memory capacity it can be sensible
to switch of the cache.

Cenon Expert When the expert mode is switched on there are
no warning panels before the program carries out
the final/unchangeable function or a function that
takes a lot of time.

Remove Backups Here you can choose, whether backup files are
removed after saving a file or is they should be
kept. Backup files have the same file name with
a tilde symbol added to them, for example: ’File-
name.cenon~’
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Selection of non editable layers  If you enable this option, you can select graphic
objects, even if the layer is not editable. This can
be useful in selective CAM production.

Select objects at border only This option affects filled objects only. If active,
filled objects can be selected at their edges but not
in their area.

Cache Size

The maximum cache size determines the maximum size of the buffer used to cache
the entire working area of your document. This cache allows scrolling of huge doc-
uments without interruption. Also see "Disable Caching".
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3.1.2 Import Preferences
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Now we introduce and explain the single parts of this window:

Device for HPGL-Impaort

lblﬂ.‘ | hpgl_8Pen -

Here you can select a parameter file for the HPGL-import. The parameter-file con-
tains information about the structure of the HPGL-derivative you want to load, so that
Cenon is able to understand the code. For the creation of your own parameter-file or
the adaptation of an existing files please see section 4.4.
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Device for Gerber-impart

GErhiep | gerer 2

You can select a parameter file for the import of Gerber-files (it’s the same as with
HPGL-files). See also section 4.2.

Resolution for DXF-Import

Resolution (pointsfingh): 25.3
A —

Here you can set the resolution for the DXF-import. this value isn’t given through the
format, so that it’s possible that different programs use different resolutions for the
output. Please use the same value for the output of the file that your CAD-program
uses. Common values are *25.4° or ’1°. See also section 4.3.

PostScript-import
? Try to convert curves to arcs ||
Flatten Text [ |

Here you can decide whether you want to transform the curves into arcs for the
PostScript-import or not. The transformation will only be carried out when it is
sensible. You can also enter whether the text should be divided into paths during the
import or not (this is necessary for some Postscript-files to ensure that the display is
not distorted/falsified). See also section 4.5.

DIN-Import

% | Default [ s]

Here you can set the device for the DIN Import. This is used to import drill data
in different derivates of the DIN format (Excellon, Sieb&Meyer). If you select the
Default entry, the import tries to detect the format of the file itself. This is the prefered
setting for Excellon and Sieb&Meyer.
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Colors to layer [ |

When you switch on this function Cenon will generate an extra layer for each color
automatically when you import a graphic with more than one color. The colors are
distributed correspondingly.

Fill objects |
Enabling this functions, all imported graphics is tried to be joined in a filled path.

This usually only works if your data is prepared in a manner suitable for building a
path.

3.1.3 Export Preferences

Flatten Text " |
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Flatten Text [ |

If you activate this option text is converted to vectors on export. This ensures that
fonts look like expected and should be if you want to export the data for output on a
device. However, if you want to import the graphic to another program, you probably
want to have this option disabled. The option only applies to export formats which
support text, like PostScript and DXF.

3.2 Import of graphic files
Cenon is able to import the following data formats:

* PostScript, PDF, Adobe Illustrator 3.0

 HPGL

* DXF

* Gerber

* Scalable Vector Graphics (SVG)

* DIN, Excellon, Sieb&Meyer 1000, Sieb&Meyer 3000
» Rasterimages (TIFF, PNG, GIF, JPG, ...)

* Type 1 Fonts im Font Package

When you click on the entry open in the menu document you get a file selection
window. You can load a file that is available in one of the formats mentioned be-
fore. The following file formats are assigned to the following extensions (see also
section 1.9):
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PostScript .eps, .ps, .ai
PDF .pdf

DXF .dxf

HPGL .hpgl, .hgl, .plt
Gerber .gerber, .ger
SVG .SVg

DIN .din, .drl

Fonts .font

Raster images | .tiff, .tif, .gif, ...
Cenon Projects | .cenon

After you have left the file selection window with a double-click on the wanted file
or with a click on OK, Cenon loads the file.

Import to existing project

You can also import to a dedicated layer (resp. create new layers) of your current
project by using the Document > Import menu item.

Import to

' Selected layer

With this pop up menu in the Open Panel, you can select how to import a graphics

file.

Selected Layer

New Layer(s)

All elements of the imported graphic are added to the layer se-
lected in the Layer-Inspector.

The objects from the imported file are placed on newly created
layers. If the file contains layer information (like DXF), then lay-
ers are create with the names from the file. Otherwise, all graphic
elements are placed on a single new layer.

You probably want to create new layers, when importing DXF
files or drill data.



68

CHAPTER 3. REFERENCE PART - THE FUNCTIONS OF CENON

Existing Layer(s) Existing layers are reused as much as possible. The layers are

emptied before new data is added.

If layer information is available from the imported file (like DXF),
then layers with the same name are reused.

If the preferences option "Colors to Layers" is activated (see sec-
tion 3.1.2), then the imported graphic objects are placed upon lay-
ers providing reference objects of the same color.

If layers are missing, there is the choice to create new layers or
skip these elements.

Using this option, you can recycle existing settings of layers. This
can be extremely useful in a series production to have everything
ready to go.

For more information and known limitations of the Graphic Formats also see sec-

tion 4.1.2.

3.3 The menus of Cenon

In this section we will describe the functions in the order of the entries in the menu.
When you look for a special information about a special entry you can surely find it
here.

Cenon

File

Edit

ile Edit Format Tools Display Window Help

Here you can retrieve some basic setting and information,
preferences, etc.

With the document-menu you can open, save and create a
document, projects and graphics. Additionally you can im-
port text data for mass production. See section 3.3.2.

The edit-menu offers functions to work on the graphic. See
section 3.3.3.
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Format

Tools

Display

Window

Help

Print

Hide

Quit

The format-menu offers functions that concern the layout of
the page and the texts. See section 3.3.4.

In this tool-menu you can find the tool-panels of Cenon. For
example the inspector and the tool-bar. See also section 3.3.5.

The display-menu offers functions that concern the display
of the graphic. See section 3.3.6.

The window-menu shows all the graphic windows.

Cenon documentation, Links to the web site, Update-Panel,

Printing. The printing panel appears, which is also used for
separating colors and writing PostScript into file.

Using this item, you can hide Cenon without having to quit
the programm. With a double click on the application icon
you can reopen Cenon.

With this command you can quit the program.
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3.3.1 The Cenon- or Info-Menu

|  About Cenon ... |
Preferences ...
Project Settings ... 385
License ...
Services 2
Hide Cenon 38H
Hide Others
Quit Cenon #E0

About Cenon The Info-Panel of Cenon

Preferences The Preferences Panel of Cenon. Here you can configure
general settings of Cenon. See section 3.1.

Project Settings Document related information and settings. Here you
can provide Copyright information to your document,
and settings, which only apply to the document. See sec-
tion 3.5.

License commercial editions of Cenon like Cenon CAM, may
ask for a valid license key.

Hide Cenon Hide the Cenon application

Hide Others Hide all other applications, except Cenon

Quit Cenon Terminate the program
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3.3.2 The File- or Document-Menu

lﬁﬂ Edit Format .!]._:lalﬁ.

New ... 28N
Open ... #0
Open Barcode ...

Import ...

import Text ...

Revert To Saved ... #U
Save 38Ss
Save As ... {r385
Print ... *P

Save Output ...

New

Open...

Import...

Import Text...

This command creates a new document.

This command brings up the Open-Panel. Here you can
select the file you want to open. You also select a file
for import here. The extension of the file is used for
identification of the format.

Here you can import all import formats of Cenon to the
current project. The Open-Panel offers you the choice to
import to the selected layer (of the Layer-Inspector sec-
tion 3.6.19]) or create new layers for the imported files.
See Section 3.2

Here you can load a text file. This can be used to produce
different signs of the same geometry in mass production.

The strings which are extracted from this file are dis-
tributed on Text graphics. Before you start to import a
text file you have to place corresponding Text objects in
your project.
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= 2 IR0k e
| No character conversion v

In the Open-Panel for the text import you can select how
to sort the strings into your project’s Text graphics:
* row by row from the upper/left to lower/right
* row by row from the lower/left to upper/right
* column by column from the upper/left to the lower/right

* column by column from the lower/left to the up-
per/right

* column by column from the upper/right to the lower/left
The file is a simple list of strings separated with a Space
character, Newline, or Tabulator (TAB). If you have space
in your strings you need to place the string inside double

quotes or use TABs to separate your strings (Is a TAB in
your text, TABs are used as the separating character):

text]l text2 text3
or
"text 1" "text 2" "text 3"

If you have to insert a Newline or TAB in your strings
you can use '\n’ respective ’\t’ in your text.

"Line 1\nLine 2" "Line 1\nLine 2"

Tip:

o If the text you want to import is in a different for-
mat, the search/replace function of a common text
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editor can help you a lot to change the formatting.

Save This command saves the document with the current name.
If the document is new, the Save-Panel appears (see Save
As).

Save As... The Save-Panel appears. Here you can save your doc-

ument with a new name. Additionally the Save-Panel
offers the possibility to export your file in different for-
mats:

Format

’i Cenon (.cenon) - ]

In this pop-up menu you can select the export format.
Disabled items mean that this entry is not applicable or
not implemented yet.

Cenon Saves the file as Cenon document

PostScript Exports the file as Encapsulated PostScript
(EPS)

Gerber Exports the file in the Extended Ger-
ber format (used for Printed Circuit
Boards)

DXF Exports the file as DXF

HPGL Exports the file as HPGL

Typel Font Exports a previously loaded Typel
font

Revert to Saved This command loads the last version of the document.

The changes of the current document will be lost.

Print Print the Document. You can also save as PDF here.
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Save Output... Cenon CAM: Here you can save the data in a file instead
of sending the output directly to a machine. The same
setting and starting positions are used (as when you send
it directly to an output-machine).

3.3.3 The Edit-Menu

| Cut #EX |
Copy ##®C
Paste AV
Delete

Undo New Line HZ

Red

=L (S-S

Build Contour ...

Join #]
Split {188
Punch or Unlite 3l
Croup #0
unaroup L e
Mirror 3 M
Rotate 90° 3R
Reverse Direction gD
Select Equal %BE
Select Color

Select All R A

Special Characters... #T

Cut
Copy

Paste Cutting out, copying and inserting (paste) function in the
usual way.
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Delete

Undo, Redo

Build Contour...

Join

Split

Punch/Unite

Cut cuts the selected objects from the document and stores
them in the background. Copy copies the selected objects to
the buffer in the background. Paste inserts the stored objects
into the current document.

Tip (Smart Paste): After the first paste of the buffer, you can
move the position of the inserted objects. The next paste will
be inserted at a distance to its predecessor using this offset,
as will all consecutive pastes.

With this command the objects are deleted.

With Undo the last operation is undone. With Redo the un-
done operation is restored.

The Contour-Panel appears. You can generate the contour of
the object here. With this panel you can create the contour of
an object. See section 3.13.

This command unites single objects together in a path. When
you unite the objects you can either select two ending points
and unite them or you can combine many objects to a unit.
When the first selected object is a path all other selected ob-
jects are added to this path.

If you select an image and a closed path object (Path, Cir-
cle, Rectangle, Polyline), then the image is clipped from the
path object. You can use this to expose an image from its
background.

This command splits paths into single objects.

This command removes hidden (covered) areas of all selected
and filled graphic objects.
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If the selected objects have different colors, the elements on
top are punched out of the element below. If the overlapping
objects have the same color they are united.

Group Here you can group different objects so that you can handle
them easier than single objects.

Ungroup Here you can rollback the grouping. The objects remain in
the twisted or mirrored status in which they were transformed
while they were in the group.

Mirror This command mirrors the selected object.

Rotate 90° This command rotates the selected objects by 90 degrees around
the center of all the selected objects.

Reverse Direction For elements with direction (Arc, Rectangle, PolyLine, Path),
this will reverse the winding direction of the object.

Set Start Set the start point for Path objects. After selecting a vertex of
a path, you can set the selected point as the starting point of
the path.

Select Equal This command selects all objects that are equal with the ob-

jects that have been selected already.

Select Color This command selects all the objects that have got the same
color like the objects that have been selected already. This
entry in the menu is very practical when the colors of the
imported files are meant to be distributed on different layers.
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Select All All the objects of the displayed layers are selected.

3.3.4 The Format-Menu

Format I

| Font [ 2
Text [
Grid (2
Bring To Front 36 8
Bring Forward 3(

Send To Back

3 3

Send Backward
Working Area ... {r#A
Page Layout ... fraeP
Optimize Moves {80

Font With this menu you get to the common sub-menu to set
the font. Most entries are only active, if text is beeing
edited.

Font Panel ... #T
Bold 3B
Italic |
Underline

Kern >
Ligature >
Baseline >
Copy Font #3
Paste Font 34

Here you can:

¢ call the Font-Panel (Keys: Cmd-t) and select a new
font, type or size.
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change the selected text region to bold and back to
normal (Keys: Cmd-b)

set the selected text region to italic and back to nor-
mal (Keys:Cmd-i)

underline the selected text region and go back to
normal

change the kerning of the selected text region. The
sub menu allows you to tighten or loosen the kern-
ing, or go back to the default. The kerning deter-
mines the distance of the characters in the text.

move the base line of the selected text within the
sub menu. The selected text can be raised or low-
ered. Superscript and subscript offer values most
commonly used. Using raise and lower you can
change the base line in finer steps.

copy and paste the font style of the selected text
region (Tasten: Cmd-3 und Cmd-4).

Text With this menu you reach the usual text menu to change
the text parameters. The menu is only active, if you are
editing text.

Align Left <
Center 38—
Align Right g6
v Show Ruler {+3R
Copy Ruler 3®1
Paste Ruler 32

Ve 1 Fdli

Here you can:

* align the selected text region. You can align text to

the left (Cmd-<), center (Cmd-) or right (Cmd->).
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Grid

Bring to Front

* toggle the text ruler (Cmd-R)

* copy (Cmd-1) and paste (Cmd-2) the text ruler to
other positions in your text.

» convert the selected text object into a path object.
This is very useful, if you want to use operations
on a text, which are only possible for path objects.
For example, if you need text with a color shading.

* bind the selected text object on a path object (e.g.
Line, Polyline, Arc, or Curve). See Editing a Textpath
in section 3.12.9.

Here you can set the grid. A grid is used to attract the
mouse pointer to fixed positions, which makes it much
easier to construct precisely.

Turn GCrid On ¥+

Align to Grid 3+

Set ... 3

Have you set the grid, you can switch it off and on with
the top most menu entry. Set opens the Grid-Panel:

B.&8.0 Grid (ONG &)

Distance: &

" mm )

Here you can set the distance between the grid lines. You
can choose the unit of measurement in the pop-up menu.
Press Set to create a grid with the new distance.
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Send To Back

Working Area...

Page Layout...

With this menu items you can move objects to the fore-
ground or background. So you can influence the order
of the elements when displayed. When an object cannot
be selected because it is hidden behind another object,
you can send the other object to the back using ’Send to
Back’.

The selected graphic object can be send all the way to
the back or front, or just a single graphic object further
to the back or front.

The Working-Area panel appears. Here you can enter
the size of the working area. The measuring unit of the
size is taken over from the Preferences-Panel.

N N S

Working Area

 Width [mm]: 555
Height [mm]: 421

The working area is displayed as white background in-
side the Graphic-Window.

The Page-Layout panel appears. Here you can set the
page format for the printing.

3.3.5 The Tool-Menu

The tool menu gives access to the different tool-panels of Cenon. Some items appear
only if the respective module is installed.
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Colors ... {+38C
Inspector ...

Batch Production ... {+3B
Transform Panel ... {+8F
Intersection Panel ... 3l
Vectorize Images ... {3V
CAM Panel ...

Teach In Panel ...

Tools... The tool-bar appears with which you can switch the editing
mode of Cenon. When you start the program the Tool-Bar is
opened automatically. See section 3.4.

Colors... The Color-Panel appears. You need it to assign another color
to elements of your graphic.

Inspector... The inspector appears. It shows the characteristics of the dif-
ferent graphic elements and it allows also changes/transformations.
See section 3.6.

Batch Production... ~ The Batch-Production Panel appears. Here you can distribute
the graphic on the working area. See section 3.10.

Transform-Panel... The Transform-Panel appears. Here you can carry out several
transformations (scale, rotate, align, mix). See section 3.8 for
more information.

Project-Settings... The Project-Settings Panel allows you to set settings and in-
formation (like Author and remarks) for your current project.
See section 3.5 for details.

Intersection-Panel...  The Intersection-Panel allows you to set different elements
on intersection points of your current graphic. This can be
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Vectorize Images

CAM-Panel...

Teach-In Panel...

useful if you like to distribute large amounts of drill markers
in a grid. See section 3.9 for further details.

Vectorizing of raster images. See section 3.14 for further de-
tails.

Only available in Cenon CAM. The CAM-Panel of the op-
tional CAM module appears. The CAM-Panel is opened au-
tomatically after you have started the program. It is used for
the management of the layers and tools and to control the
machine. See section ??.

Only available in Cenon CAM. The Teach-In panel of the op-
tional CAM module allows the collection of positions from a
machine. You can position a plotter or machine over a tem-
plate using the Control-Panel (section ??). The positions then
can be captured into the document as a mark via mouse click
in the Teach-In Panel.

The collected mark objects can be converted to 2-D or 3-D
lines from within the Teach-In Panel.

More entries can appear with installation of Cenon modules. A description of these

entries can be found in

the corresponding documentation.

3.3.6 The Display-Menu

The items of this menu

pH:151 Windo

|  Show Coordinates
Show Directions
Show Moves
Show Tool Diameter

control features displayed in a document window.

NBE |
4+%D
T8EM
48T
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Show Coordinates Enables the coordinate display in the top area of
the document window.

Show Directions Here you can see the direction of the vectors dis-
played as little arrows on the border of the graphic
objects.

More entries appear with installation of Cenon modules. A description of these en-
tries can be found in the corresponding documentation.

3.3.7 The Windows-Menu

o

| Bring All to Front
Miniaturize Window
Close Window W

Take Snapshot ...
Restore Snapshot ...

v UNTITLED

Take Snapshot This menu entry lets you save the name, position,
and size of all documents on the screen. When
starting Cenon the next time, all documents will
be automatically loaded and positioned. You can
also give your snapshots a name to restore differ-
ent working situation.

Restore Snapshot You can pick a snapshot to be restored.
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3.3.8 The Help-Menu

The Help menu provides documentation, links to the web site, and the Update Panel.

Help

sexeen (D

Cenon Web Page
Release Notes
Online FAQ

Send Feedback ...
Check for Updates ...

Cenan Manual
Cenaon Astro

Cenon CAM
Cenon Web Page This brings you to the web site of your flavour of
Cenon.
Online FAQ Frequently Asked Questions.
Send Feedback Opens a new E-Mail.
Check for Updates This will check with our server, if a new release

of Cenon is available. If a new version of Cenon
is available, the Update Panel will open and will
give you information on what’s available. The
Update-Panel also allows you to download a new
Cenon package.

Cenon Manual The Cenon Manuals of Cenon and installed flavours.
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3.4

The Tool-Bar

You can switch the different editing-modes of Cenon with the Tool-Bar.

- Group-mode. You can move and select all the elements in this mode. You
can get to this mode from any other mode when you press the Cmd-key.

O

place o

Rotate. In this mode you can rotate elements with the mouse. Click at some
n a selected graphic and drag the mouse to rotate the object.

74

Cutter. In this mode you can split graphic objects at the position of your

mouse

\T+

click.

Add Vertex. This mode allows adding vertices into Paths and Polylines. A

mouse

click to a position on the selected path or polyline adds the new vertex.

&

mouse.

Countersink. In this mode you can place countersinks at the position of the
See the Inspector in section 3.6.11 for Details.

%

Threads. Here you can place threads. See the Thread-Inspector in sec-

tion 3.6.3 for Details.

&

sl

Marking. In this mode you can place marks. A marking is normally used to

set a drilling.

Line. In this mode you can draw lines. With the first click you start a line

and with every further click you set a further part of the line. With a double-click on
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the left mouse-button or when you leave the mode the connection is interrupted. The
connection is also ended when the line has got no extent/dimension.

Whenever you meet the end of the element you will hear a signal.

9 PolyLine. In this mode you can create poly lines. A PolyLine is like a
path composed from lines. The first click starts the PolyLine. The next clicks add
further line segments. You can end the PolyLine with a double click or by leaving
the PolyLine mode.

Whenever you hit a edge point of another graphic, a signal is played.

Arec. The first click with the mouse sets the starting position (starting angle).
The second click defines the center and the last click defines the endpoint (end angle).

Rectangle. The first mouse-click sets/defines the first edge, the second click
the opposite edge. The rectangle is saved and worked with a polygon.

-
Curve. The first mouse-click sets the starting position, the second the end-
point. The next two mouse-clicks set the anchor points of the curve.

Text

Text. Here you can create text. A complete text-frame is offered, that means
you have the same editing-functions like in a rich text editor.

Tips: You can set the Font style with the Menu Format> Font. You can move the
color directly from the Color-Panel into selected text. You can copy and paste se-
lected text to other applications. You can also copy text from other applications into
your Cenon document.

Webs. Webs are used in CAM applications to keep the working piece at its
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position during cutting. The webs are spared on cutting. Place the webs at good
positions around the outline of your working piece. You can adjust the width of the
webs in the Web-Inspector. For more info see section 3.6.14.

3.5 Project Settings

In this panel you can set parameter and information for your project. Using the pop-
up menu you can switch between the project settings and the project info.

3.5.1 Project Info

T i) Project Settings

| Info

as
e

Version 1.0

Author llonka Fleischmann

Copyright (C) 1995 by llonka Fleischmann

Comments  Airplane for 1.0 mm material
Type: Beech 17 Staggerwing (1932)

Fd

In the project info part you can place information regarding your project. The input
will appear at the beginning of the Cenon file, so it is also visible in a text editor.
Depending on the kind of project, the values you can enter may vary.

The following entries are the standard:

Version A place for the version number of your project
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Author Who did it? Name, eMail-Address etc. of the author
Copyright Who owns it?

Comments Here is a place for a descriptive text of the project

3.5.2 Project Settings

806 Project Settings

' General Settings "

ik
g

Unit

' paint |-

-e
)

o

The General Project-Settings allow changing the unit of measurement. If you change
the Unit from the Default ”Use Preferences” to a unit, then this unit will be used for
the document. If you leave the Default, the Preferences-Settings (see section 3.1.1)
will be used.

3.6 The Inspector-Panel

The inspector gives information about the selected graphic. The selected graphic can
also be changed here. You can open the inspector from the tool-menu. Depending
on the selected element the inspector changes its display appropriately.
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In addition to the object parameters, the inspector is also used to manage the docu-
ment layers too.

A Path.
SO\E [+ &

& .= Background
& 4= Duck (Toy)

& .= Duck (Cenon})
@ = Text Deutsch
== = Text English
& .= vhf - intersernvi
== o= vhf - CAM

f: Mave 1o Layer :]

' Duck (Cenon)

N (R 3
1: ew ] ( en'u:weé;ﬁ

At the top of the inspector panel is an icon bar. Here you can select the kind of setting
you want to modify. You can select between object coordinates, stroke width, filling
and text. Additionally you can manage the layers of your project.

To the following inspector-types you can find further information in the following
sections. The common inspector types for width, filling, text and layers are placed at
the end of the list:

* Arc Inspector - Section 3.6.5
* Curve Inspector - Section 3.6.1

* Crosshairs Inspector - Section 3.6.2
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* Group Inspector - Section 3.6.4

* Image Inspector - Section 3.6.15

* Line Inspector - Section 3.6.6

e Mark Inspector - Section 3.6.7

* Path Inspector - Section 3.6.8

* Rectangle Inspector - Section 3.6.10
» Countersink Inspector - Section 3.6.11
 Text Inspector - Section 3.6.12
 Textpath Inspector - Section 3.6.13
* Thread Inspector - Section 3.6.3

* Web Inspector - Section 3.6.14

* Width Inspector - Section 3.6.16

* Fill Inspector - Section 3.6.17
 Texttype Inspector - Section 3.6.18

e Layer Inspector - Section 3.6.19

Tips:

* When you select more than one element of the same type you can change them
together. In this case, the inspector shows the parameters of the first selected
object.
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3.6.1 The Curve Inspector

HO& +2

The curve-inspector shows information about the selected curve. The selected curve
(or more than one) can also be altered here.

Start Paint End Paoint
30 4 b ¢ 4 b
25 4 p s 4»
Here you can see and set the start point and the endpoint of the curve.

Control Point 1 - Control Point 2 -
0 dp [ b
48.5 4 p |eo 4 b
Here the control points of the curve are displayed and can be changed.

Lock [ |

Here you can lock the position of the curve to prevent moving it accidentally. You
still can select the curve and change its parameters using the inspector.

3.6.2 The Crosshairs Inspector

You can see the crosshairs inspector on the display when no object is selected. It
shows the position of the crosshairs that defines the zero point of all measurement as
well as output.
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e = ="

Crosshairs

FoE [+ =
Position -
v 4D
—

Here you can set the position of the crosshairs. For most applications this will simply

be 0/0. The coordinates of the crosshairs are an exception, because they are displayed
in absolute coordinates (relative to the lower left corner of the window).

3.6.3 The Thread Inspector

The Thread-Inspector shows information about the selected thread. The selected
thread (or more than one) can be altered here, too.

The output of a thread performs a 360 degree spiral starting at the bottom of an
existing hole, and lifting the tool by the value of the pitch of the assigned tool. Note:
You have to assign a thread cutter to the layer, to get this work!

Center )
376 4 b
248 4 b
Here you can see and set the position of the thread. This is it’s center point.
Mominal Diameter

Ca—

Here you can see and set the nominal diameter of the thread. This is the same as for
the screw which should fit.
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Lock [ |

Here you can lock the position of the thread.

Leftturn [ |

Activate this switch if you need left turned threads.

3.6.4 The Group-Inspector

POl +=

In the group-inspector you can find information about the selected group. The se-
lected group (or more than one) can be changed here.

Crigin
132 4 D>
134 4 D>

Here you can set the position of the group. The position is the lower left corner of a
rectangle enclosing the group elements.

Size
35 4 D
35 4 D

Here you can set the size of the group. All elements of the group will be scaled to the
new size. This operation is not without problems if the group contains text or arcs:

* If your group contains text, scaling may render text invisible in some rare cases.
If this happens, you have to ungroup the group and adjust the height of the text
to be visible again.

* If you set the group size arcs will be converted to curves.
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Lock [ |

Use this switch to fix the position of the group. The group can still be selected and
changed inside the inspector, but not handled with the mouse.

3.6.5 The Arc-Inspector

0L +2

In the arc-inspector you can find information about the selected arc. The selected arc
(or more than one) can be altered here.

Center _
376 4 b
248 4 b
In this field you can see and set the coordinates of the center of the arc.
Radius )
34 4 b
Here you can see and change the radius of the arc.

Start Angle

| {=0=—)

Here you can see the starting angle. You can set/enter the starting angle from -360 to
360 degrees.

Angle

20 | —0= )

Here you can see and set the angle from -360 to 360 degrees. A positive angle means
that the angle is drawn counterclockwise (positive direction mathematically).
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Lock [ |

Use this switch to fix the position of the arc. The arc can still be selected and edited
using the inspector, but not handled with the mouse.

Filling: You can fill an arc using the Fill-Inspector. If you fill an open arc (<360°),
two lines will be added to close the arc segment (piece of cake).

3.6.6 The Line-Inspector

710 |+ 2

In the line-inspector you can see information about the selected line. The selected
line (or more than one) can be changed.

Start Paint )
30 4 b
C—

Here you can see and set the startpoint of the line.

Angle

20 | —0= )

Here you can set the direction of the line. Starting at the startpoint the vector heads
in the direction provided here.

Length

TR

The length of the line.

End Point )
m_ 14)
4D

69.641
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The endpoint of the line.

Lock [ |

Here you can lock the position of the line against accidentally changing with the
mouse. You can still select the line and change values with the inspector.

3.6.7 The Mark-Inspector

FoE |+ =2

The Marking-Inspector shows the position of the selected marking. You can use a
marking for marking or for drilling.

Pasition
30 4 b
9 4>

The coordinate of a marking. The coordinate can be three dimensional.

3-D Marker [

Here you can select, if the marking shall be three dimensional. If you check the
switch the Z field of the coordinates is editable.
Loek [ |

Here you can lock the position of the mark against accidentally moving with the
mouse. You can still select the mark and change values with the inspector.

3.6.8 The Path-Inspector

2o&+=
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In the Path-Inspector you can find information about the selected path. You can
change the selected path (or more than one) here.

Crigin Size

132 D w254 4 b

aa | d D H: 254 4 b

Here you can set the position and the size of the path.

Selected Point )

447 d >

1275 d >
Here you can see and set the selected point of the path. The selected point is marked
with a selecting point that is a bit bigger.

Lock [ |

Use this switch to fix the position of the path. The path can still be selected and
edited using the inspector, but not handled with the mouse.

Filling: You can fill a path using the Fill-Inspector. To fill a path it needs a closed
contour. If you fill a open path, the path will be closed automatically with a line.

Tip:

* A path should not have overlapping sub-paths because otherwise the calcula-
tion of the contour can be wrong.

3.6.9 The Polyline-Inspector

Hol& | +2

In the Polyline-Inspector you can find coordinate information about the selected
Polyline and you can modify it.
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Selected Point
447 4 D
127.5 4 D

Here you can see and set the selected point of the polyline. The selected point is
marked with a selecting point that is a bit bigger.

Lock [ |

Use this switch to fix the position of the polyline. The polyline can still be selected
and edited using the inspector, but not handled with the mouse.

3.6.10 The Rectangle-Inspector

B0 |+ 2

The Rectangle-Inspector shows information about the selected rectangle. The se-
lected rectangle (or more than one) can be changed here.

Origin Size

132 | D w254 4D

134 4 > H 254 4 >
Here you can set the position and the size of the rectangle.

Angle

w0 |4 —6= )

Here you can set the width and the rotation angle from 0 to 360 degrees.
Corner Radius
; 4>

Here you can set the edge-radius of the rectangle. The rectangle has got rounded
edges when the edge-radius is not 0.
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Loek [ |

Use this switch to fix the position of the rectangle. The rectangle can still be selected
and edited using the inspector, but not handled with the mouse.

3.6.11 The Countersink-Inspector

The Countersink-Inspector shows information about the selected countersink. The
selected item (or more than one) can also be changed here.

Crigin
E
134 4 D>

Here you can set the position of the item. This is the position of the center.

Type

B 5 ()

This part lets you choose the type of the countersink. The main difference between
the two types is the rim. The pop up allows you to toggle between metric and inch

type.

Metrics -

[ M4 ke
Hole @3 (d1); 4.5
Head @ (d2); B.6

Head Haight {t1); 2.1

Head Brim (t2); 0

Step Size: 0.1
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This area shows the metrics of the countersink. In the pop up menu you can select
the desired metrics by name. The metrics are then displayed in the fields.

Hole @ (d1) The diameter of the hole for the screw

Head @ (d2) The diameter of the head of the screw

Head height (t1) The height of the entire head of the screw including brim
Head brim (t2) The height of the head brim of the screw (only second type)
Step size This entry is used for cutting. It is the step size the cutter

increments while stepping down the cone of the head part
of the countersink.

medium fine

t1 It

| f | &

—= di —— — df ——

If you need to customize the settings choose Custom from the pop up menu. Then
you can modify the values in the text fields.

You can modify the names (and relating parameters) listed inside the pop up menu by
editing the file SinkingMetrics.plist. The file is located within the Cenon application
bundle and has to be copied to the User Library for editing (example for Apple):
Cenon.app/Contents/Resources/SinkingMetrics.plist > USER/Library/Application Sup-
port/Cenon/

(see section 5.1).
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3.6.12 The Text-Inspector

DL | 2=

In the text-inspector you can find information about the selected text.

Crigin
132 4 D>
134 4 D>

Here you can set the position of the text box. This is the lower left corner of the box.

Box Size
127 4 b
5.6444 4 b

Here you can set the width and height of the textbox.

Angle

20 | —0= )

Here you can set the rotation angle of the text between 0 and 360 degrees.

Serial Mumber [

With this button you can use the text as a serial number for batch production. The
trailing numbers are counted automatically. Only a Text and a TextPath can be used
as a serial number!

Fit horizontal [ |

When you use this button Cenon will fit in the text into the text-box. The height of
the text is preserved. Only the distance between the words and letters is reduced (the
kerning is tightened).

Center vertical [ |

Centers the text vertically inside the text-box.
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Lock [ |

Use this switch to fix the position of the text. The text can still be selected and
edited, but not moved. This function is especially useful to create text masks. Once
you have locked the position of a text you can still edit it, but not move. This way
you can easily create forms.

Tips:

¢ The color of the text can be moved with the mouse from the color-field into the
selected part of the text. so only a part of the text can be colored.

3.6.13 The Textpath-Inspector

BOE [+ =

In the Textpath-Inspector you can find information about the selected Textpath. A
Textpath is a text placed on a line, polyline, arc, or curve. Depending on the object the
text is bind to, the appearance of the inspector will change and display the appropriate
kind of fields. Take a look at the line, polyline, arc or curve inspector for a description
of these fields.

See section 3.12.9 how to create a text path.

Show Path V!

Here you can decide whether the path, which the text is bound to, should be displayed
or not.
Serial Mumber [

With this button you can use the text as a serial number for batch production. The
trailing numbers are counted automatically. Only a Text and a TextPath can be used
as a serial number!

Lock [ |
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Use this switch to fix the position of the text. The text can still be selected and edited,
but not moved.

3.6.14 The Web-Inspector

L=

In the Web-Inspector you can set the positions of webs, which should survive the
cutting of the contour of your working piece.

The working piece will not be completely separated from the material. The webs
will still connect it with the material.

Origin

13z 4 D

134 4 D

Here you can set the position of the web. This is the center of the object.
Width

T dO—)

Here you can set the size of the web. The size determines the size of the gap in the
calculated output of the paths this object sits on.

Lock | |

Use this switch to fix the position of the web. The web can still be selected, but not
moved with the mouse.

Note:

* If you have disabled stepwise cutting in the Layer-Panel, the web remains in
the entire thickness of the material. Select stepwise cutting and provide the
thickness of the web with the final step.
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3.6.15 The Image-Inspector

2IO\& |+ =

The image inspector shows the parameters of the selected image. If more than one
image is selected, the parameters of the first selected image are displayed. Parameters
can be changed here, too.

Crigin
132 4 D>
134 4 D>

Here you can set the position of the image. This is the lower left corner of the image.
Size

W: 25.4 4 >

H: 25.4 4 >

Here you can change the size of the image.

Name

sgricannon.jpg

The name of the image.

| IPG ¢

Compression (%) O

Here you can choose how to compress the image. Cenon saves images in a common
image format like TIFF to the project-file. As images especially in publishing may
become quite large, Cenon allows several compressions.

Usually Cenon will save an image in the TIFF format. You can compress TIFF
images as LZW without losing quality. Free software sometimes doesn’t offer the
LZW compression because of patent issues. The alternative is the JPEG format. For
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the JPEG format you have to provide a compression factor to control how much the
image will be compressed without losing too much quality. The less you compress
JPEG images, the better the quality. A compression of 10% is usually without visible
loss of quality.

Thumbnail E

Activating this switch will create a thumbnail image of a large image. A thumbnail
is a low resolution copy (72 dpi) of an image. This small image doesn’t need much
memory compared to the repro version and saves a lot of memory and time when
working. For printing and export, the repro version of the image will be used in any
case.

Lock [ |

Use this switch to fix the position of the image. The image can still be selected, but
no longer moved with the mouse.

3.6.16 The Width Inspector

&L+ 2

The width is only available for objects which allow a border width like Line, Arc,
Curve or Path.

| Stroked &

Here you can select, weather the object border is stroked.

Color

Here you can set the color of stroked objects. With a click on the border of the
color field the Color-Panel appears to change color. Cenon allows separate colors for
stroking and filling of objects. Here you can set the color for stroking.
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Width

[ {O=——b

Here you can set the width used to stroke the object.

3.6.17 The Fill-Inspector

OO +=

The filling is only available for objects which can be filled, like Text, Path, Polyline.

 Axial =

Here you can select the kind of filling you desire for the graphic object, if any at all.
The following kinds of filling are supported:

1. Simple filling in one color. The lower Arc is filled with a different color.

2. Linear color shading: The shading starts with a start color towards an end color
using the given step width. The lower Arc is filled with bigger steps.

3. Radial Shading: This shading starts from a center of the object.

4. Axial Shading: This shading starts on one side of the object and goes in axial
direction. This kind of filling is a little tricky to adjust to achieve the desired
results. The example was build using 6 Arcs with different centers and angles.



3.6. THE INSPECTOR-PANEL 107

Color

Here you set the color or start color of the selected graphic object. If you have
selected more than one object, then the color of the first selected object is displayed.
With a click on the border of the color well, the Color-Panel appears, where you can
change the color.

If the border of the color well is white, then the color selected in the Color-Panel will
be set directly. If the border is not selected, you can drag and drop a color from the
Color-Panel into the color well.

Graduate Color

Here you can set the end color of the selected object. With a click on the border of
the field you get the Color-Panel to change the color.

Graduate Angle

o 4O——)>

Here you can set the direction of the shading.

Radial
Center

For radial shading, you can move the knob inside the square to determine the center
of the filling. The square symbolizes the bounding box of the graphic object.

Stepwidth 5 \j ;)
e
Here you can set the stepwidth of the color shading. The stepwidth is also used on
export. If you create documents for printing a smaller step width might be better as
the default.
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3.6.18 The Texttype-Inspector

|Te>¢ DL MQ

In the Accessory-Inspector, select ”Text” from the pop-up menu.

| Text & J

The Text part is only available for Text and TextPath objects.

Faont Size

3.3956 4 b

Here you can set the font size for the entire textbox. If you want to change the text
size for a selected range of characters only, you can use the Font-Panel (section 3.3.4)
to do so.

Line Height

sser )

Here you can set the line height for the entire text box. If you want to change the line
height for a selected range of characters only, you can use the text ruler (section 3.3.4)
to do so.

3.6.19 The Layer-Inspector

ORRE |+ =

At this place inside the Inspector-Panel you find the layer management of Cenon.
Here you can add, rename, reorder and remove document layers.
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& .= Background

& .= Duck (Toy)

& .= Duck (Cenon)
& .= Text Deutsch
= o= Text English
& .= vhf - interservil
& = vhf - CAM

This part lists all the layers of your document. Here you can select and reorder layers.

& = By clicking on the eyes you can switch on and off the display of a layer.
A layer with closed eye will neither be displayed nor printed or exported. A layer
which is not displayed can’t be edited too.

7~ By clicking the pencil you can decide, if a layer is editable or not. A layer
with broken pencil can’t be edited. This can be used to protect your layer from
accidental modifications.

The layers in the list can be reordered by dragging them to the new position in the
list while the Control-Key on the keyboard is pressed.

|': Move 1o Layer q‘l

This button moves the selected objects of your document to the selected layer in the
layer list. Therefor all participating layers must be visible and editable! None of the
graphic objects should be locked.

Duck (Cenan)

Here you can change the name of the selected layer in the list. Press Enter on your
keyboard to set the new name.

|fr Mew W‘] { Remove )

A

With these buttons you can add and remove layers.

[New | [Remaove |

Here you can create a new layer or remove the selected layer.
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3.7 Layer Details

The Layer Details allow more settings for each layer.
The panel is reached by a double click on a layer in the Layer Inspector.

(e Layer -i%'lﬁzl

_f Standard Layer

£

E use for batch production

Geen)

The pop-up menu allows the change of the type of a layer. This determines the
behaviour and use of a layer. The following possibilities are available:

Standard Layer

Page

Template

A layer of this kind is completely on it’s own. When printing
such a layer will be printed only, if the eye in the Inspector is
open. This type is the default.

A page is used for multi page documents. When printing each
page is printed to a new page. All displayed standard layers are
included on every page. The special template layers are included
according to their purpose.

If you enable (open eye) a page in the Layer-Inspector, all other
pages are disabled.

A template usually contains wildcards, which are filled with life
at a different place. Using a template you can define variable
parameters.

The elements on this template now, are used on any page. Here



3.8. TRANSFORM-PANEL 111

you can define a page numbering, which is displayed on even as
well as odd pages, for example. See also Chapter 3.16.

Template Odd This template provides elements used for odd pages only. For
example a page number which should sit at the outside of pages.

Template Even  This template contains variable elements for even pages.

The switch “Use for Batch Production” allows to have layers that are not included
when creating multiples. For example if you create multiples of a callcard, but want
to spare the layer with the crop-marks.

3.8 Transform-Panel
With the Transform-Panel you can transform selected graphic objects. The Transform-
Panel is called from the Menu Tools > Transform-Panel.

With the pop-up menu you can select the different kinds of transform operations
explained below. The transform operations usally work upon the selected objects.



112 CHAPTER 3. REFERENCE PART - THE FUNCTIONS OF CENON

3.8.1 Scaling

£ 7 ™ Transform

- S

Scale

Uniform Scale [_| '

—

¥: 100

In this part of the Transform-Panel you can scale objects in x and y direction. Select
the switch to keep the aspect ratio of the objects. That means that the scaling is
carried out with the same value in x- and y-direction.

You enter the percentage of the scale into the fields. For example when you enter e.g.
110 the graphic is enlarged to 110 % of the original size (that means 10 % bigger).

As soon as you click on Set the scaling is carried out.
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3.8.2 Moving

M M Transform

| @ Kl %=,
;.“J ! ": -+- :f‘T
Move
' Move Relative I:]
X:_1ﬂﬂ
¥: 0

You can move the selected graphic objects relative or absolute.

Move Relative The entered coordinates are added to the position of the objects.
Negative coordinates move in the negative direction of the co-
ordinate system (e.g. x = -10 moves to the left, x = 10 moves to
the right).

Move Absolute The entered coordinates are set directly for all selected objects.
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3.8.3 Rotation

& M ™ Transform

| JI! " |i.¢..‘_.j|EE
| ¥ -EJ-}J.E":J.:-+
Hotute

Angle: 90

Here you can rotate the selected objects. The angle is given in degrees. Positive
values rotate counter clock wise.
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3.8.4 Align

& 7 Y Transform

| | O = =] |
Rl - [ESIE
Align
Horicontal
Vertical

lﬂmﬂi mﬂh

] Align Layers

Using this part of the Transform-Panel allows you to align graphic objects in several
ways. You have to select at least two objects to be able to align them. The icons
show quite clear what will happen.

By activating the switch *Align layers’, you can align complete layers instead of
single objects. This works as follows:

 Select at least one graphic object on each layer. These are the reference objects
for aligning the layers.

For each layer, the smallest rectangle enclosing the reference objects is used to
align the layers. If you want to center layers you want to select all objects on
the layers. However, if you want to align dedicated objects on the layers above
each other, then you only want to select a single object on each layer.

* One layer will not be moved and plays the role of the reference layer. If you
want to give this role to a layer, make sure the layer is not editable (see sec-
tion 3.6.19). All other layers will be aligned to this one. If all layers are
editable, the last one is used as reference layer.
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3.8.5 Mix

& M ™ Transform

d. . | | @ |
i &g
[ |] @

Mix

[ mix Layers

Locked Objects
) don't mix
() don't mix layers

Mix

Here you can mix the positions of graphic objects in several ways. This can be used
to produce unique samples of an art work e.g. a collection of engraved signatures.
This way you can add additional value to a product without having much work.

If you select the switch you can mix objects across layers. Otherwise each layer is
mixed on its own.

The radio buttons decide how to process fixed objects. You can keep them where
they are or keep them on their layer.
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3.9 Intersection-Panel

. Intersection Panel

Creates objects at |
intersections of |
selected graphics

@ Drill Marks i
() Threads
() Sinkings

o (G
) Webs |
T ——
The Intersection-Panel is used to distribute objects of differend kind upon intersec-
tion points. For example if you have to drill holes in a concentric pattern, you can

easily construct the pattern using arcs and lines. Now you can use this panel to place
drill markings on each intersection.

You can use Lines, Arcs, Curves, and Paths to create the intersections.

% Drill Marks
) Threads
() Sinkings

Here you can select the kind of object you want to create. The objects will be placed
on each intersection using default values for all parameters. Use the appropriate
Inspector-Panel (see section 3.6) to change these values to whatever you like.

Place objects of selected kind upon each intersection on editable layers.
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3.10 Batch Production

Batch Production

Distance Limits -

| Relative :| | Number of items 2 | o
X a0 b P

¥: |30 B i 2 |m|

| | Move Master Graphics to Origin

The panel for batch production (Tools > Batch Production) is for the production of
multiple duplicates. The working surface of the engraving machine is used optimally
to distribute the available graphic as often as possible on the surface. So you can
create the same object several times without making a copy of the objects or without
having to justify the starting point of the machine again.

Distance

| Relative =
X 30 >
¥:. 30 i

Here you can set the distance between the individual parts of the duplicates. If you
choose "Relative’ the distance describes the gap between the parts. You can also set
the absolute distance from part to part.
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Limits

| Number of Items 2 |

X 2
T2

In this part of the panel you can set how the duplicates are distributed. In the pop up
you can select between distribution based on the "Number of Items" or the "Size of
Material". In the two fields you can specify your choice.

[ Move Master Graphics to Origin

Here you can decide, whether to move the master parts to the origin, before the
duplicates are distributed.

| Set

After a click on "Set" the duplicate is generated. The duplicates are generated for
all layers which are enabled for batch production (see Layer-Details in section 3.7).
In our example you can see four duplicates. On the lower left side you can see
the original graphic. The display shows only the frame of the three duplicates. It’s
possible to give every part in batch production its own serial number. Therefore
choose the appropriate entry in the Text-Inspector (see section 3.6.13). On every part
the serial number is increased by one automatically.

| Copy |

When you use Copy, Cenon creates real copies of your graphic. This needs more
memory and you have to maintain all copies of the graphic! The copies are dis-
tributed like duplicates on the working area. Using copy you can edit the single
copies of the graphic.

| ~ Aemove |

Click on remove to remove the duplicates for batch production that has been gener-
ated (This makes no sense and doesn’t work for real copies!).
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.0.68 6 % DucksBatch.cenon

=
-

3.11 The Graphic Window

—~7
.

After you have loaded or created a new document it is displayed in the (following)
graphic window.
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olgils W ExampleAMP.cenon

X: 65585 Y: 58704  W:77.2014 H: 3.2067 mm | @D 100% :EJ

The crosshairs mark the zero point of coordinates. If the grid is enabled, it is aligned
to the crosshairs too.

For CAM applications, the grey frame represents the machine table. So you can
easily see if the graphic is not too big for the working area.

X: B5585 Y 58704 W: 772914 H: 3.2067

Here you can see the display of the coordinates. On the left you can see the absolute
position to zero; on the right you can see position relative to the last mouse-click.
When you create a new object you can see its size on the right.

Here you can choose the measuring unit of the display of the coordinates.
[@)(- ) 1005 +](+]

With these elements you can zoom the graphic. In the pop-up-menu you can choose
a new zooming-factor. With the buttons + and - you can zoom into and out of the
graphic. With the magnifying glass you can create a rectangle. Then the content of
the rectangle is displayed on/over the whole screen.
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Tips:

* When you press the Alt-key the operation is carried out in one direction only.
So you can move the graphic only in x- or y-direction. The same goes for
rotating.

» With the Shift-key you can select or deselect further graphic objects.

3.12 Editing

* Lines

* Rectangles
e Curves

e Arcs

e Images

* Paths

* Polylines
e Text

* Textpaths
* Groups

* Markings
* Threads

* Countersinks

e Webs

You can modify the graphic objects as follows:
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Selecting

Click on the graphic object to select it. If you press the Shift-key during this opera-
tion, you can select or deselect additional objects.

If you keep the mouse-button pressed, you can drag up a rectangle around objects.
All objects which are partly inside the rectangle become selected. If you press the
right Alt key while dragging the rectangle, only those objects are selected which are
completely inside the rectangle.

The edit-menu offers additional ways to select graphic objects:

» Use Edit> Select Color to select all objects which have the same color as the
already selected objects.

» Use Edit> Select Equal to select all object which are of the same kind as the
already selected objects.

o Use Edit> Select All to select all objects.

Moving

Click on the graphic object. Keep the mouse-button pressed to move the object. It
doesn’t matter whether the graphic object is selected or not - as long as you don’t hit
a knob.

If you want to move an entire object but want to grap it at a vertex point (where
the knobs are placed), pay attention that the object is not selected when starting the
move. This way you can move the object by snapping the grabbed point to the grid or
other object points. The distance where objects are catched, can be set in the general
preferences (see section 3.1.1). This feature is very helpful whenever you have to
attach graphics to each other.



124 CHAPTER 3. REFERENCE PART - THE FUNCTIONS OF CENON

Dragging points

To drag an end point or an anchor point (vertex) of an object you must select it first.
Then you can move the vertex by keeping the mouse-button pressed (drag). When
this point meets another point during the operation you can hear a signal, and the
point is snapped to this point. You can set the distance to which points are snapped
in the Preferences-Panel.

Copy/Cut/Paste

You can copy a selected object with the entry "copy" (menu) into the intern buffer.
It’s also possible to move it to the buffer by cutting it out. Objects that are in the buffer
you can insert in the position of the mouse with the command "paste”. When you
want to insert more than one copy of an object, the copied objects appear staggered to
each other. After you have inserted the second object you can move it. Every further
object is inserted with the same distance like the distance between the original object
and the first copy (smart paste).

Delete

You can delete a selected object with the delete entry in the menu (Edit->Delete) or
with the backspace-key.

Tips:

* When you press the Alt-key the action is carried out in one direction only
(either x- or y-direction).

* To be able to edit an object the Move-Mode must be active (see Tool-Bar sec-
tion 3.4). You can get to the Move-Mode from any other mode while pressing
the Cmd-key.
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3.12.1 Editing Lines

Create

s

To create a Line you have to activate the line mode.

* The first mouse-click sets the starting point the second the end point.
 After a line has been finished the next line starts from the end point of the last.

* The creation of the lines can be stopped with a double-click on the end point
of the line or by setting the endpoint on an existing point. You can also end
a line by setting the endpoint at an illegal coordinate or by clicking outside of
the window. In this case the line is not set. Also a right click with the mouse
will end editing.

* When you press the Cmd-key only one line is drawn or it is stopped after the
next segment.

Selecting

Click on the line to select it. The end points of the selected line are marked with
knobs. The selected end point is displayed bigger than the other one.
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Tips:

* When you press the Alt-key moving of the line or its end points is carried out
in one direction only.

3.12.2 Editing Rectangles

! |
m’ 'm|
Create

To create a Rectangle you must activate the rectangle mode.

» The first mouse-click sets a vertex, the second the opposite vertex.

* During the creation the mouse-position locks to the points near to it.

Selecting

Click on the border of the rectangle to select it. A selected rectangle is displayed
with knobs on each edge point.
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3.12.3 Editing Curves

To edit curves mind the following:

Create

7

To create a curve you have to activate the curve-mode.

* The first mouse-click sets the starting point, the second sets the endpoint of the
curve. The third and the fourth mouse-click set the anchor points.

» After you have finished the curve, the next curve starts at the endpoint of the
previous curve.

* You can end the drawing of the curve with a double-click on the endpoint or
when you set the endpoint on an existing point. You can also end a curve by
setting an illegal coordinate or by clicking outside of the window. In this case
the curve is not set.

* If you keep the Cmd-key pressed only one curve is drawn or is stopped after
the next segment.

* During the generating the mouse-position locks to the points near to it.
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Selecting

Click on a curve to select it. The end point and the anchor points are marked differ-
ently. The selected end point (on the left) is displayed bigger than the others.
Moving

If you move an endpoint the corresponding anchor point is moved with it.

Important Notes on Bezier Curves

To create nice bezier curves without surprises during output or calculations, you
should keed a few general things in mind:

¢ the anchor points of the curve should be between the start and end points.

¢ the bezier curve should always continue in the direction of a connected graph-
ics element. If two bezier curves are connected, their connecting handles
should form a straight line.

* the two handles of a bezier curve should be abould 1/3 the length of the bezier
curve and equidistant to each other.

* The follwoing image shows a bad connection of two bezier curves (top, red),
and a perfect connection of curves (bottom).

* Curve Diagnosis (Version >=4.1):
For curves joined into a path, bad handles are displayed in red color.
When moving a handle of a curve inside a path, the handle snaps along the
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ideal tangent.

Hint:

» Keep the Alt-key pressed to move a curve or handle in one direction only (hori-
contal or vertical).

3.12.4 Editing Arcs

Create

&

To create an arc you have to switch to the arc-mode.
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* The first mouse-click sets the starting point, the second sets the center and the
third sets the endpoint.

* During the generating of the Arc the mouse position locks to the points near to
it.

Selecting

Click on the arc to select it. You can see the starting point, the endpoint and the
center. The selected endpoint is bigger than the others.

Moving

You can move the arc by clicking on the center or the frame and by keeping the
mouse-button pressed.

Dragging the starting point and endpoint

You can move the starting point and the endpoint (a)round the center. So you can
transform the starting and the end angle. If you keep the Ctrl-key pressed you can
also alter the radius.

Tips:

* By pressing the Alt-key the arc can only be moved in one direction. When you
move the arc by clicking on the center the Alt-key has no function.
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3.12.5 Editing Images

Create

Images can be imported to Cenon by Drag and Drop or via Copy and Paste. Addition-
ally you can import images via the menu (File > Import...). So, many possibilities.

Exposing

You can expose an image by clipping it from a Path, Polyline, Rectangle or Arc. To
do this first create the path describing the desired contour of the image. Then select
both image and path and join the two objects using the menu (Edit>Join).

Details on how to expose an image, you can find in chapter 2 or in our tutorial:
“HowToExposelmages.cenon”.

Selecting

To select an image click on it. The selection is displayed by four knobs at the corners
of the image. This is also true for exposed images.
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Moving

You can move the image by dragging it with pressed mouse button.

Resize

You can drag the four corner points of the image to change the size of the image.

If you press the right Alt key while moving the corner point of an image, the image
will keep its natural aspect ratio.

Hint:

e If you press the right Alt key while moving an image, the movement will be
limited in one direction only. If you press the right Alt key while moving a
corner point (resize), the image keeps its aspect ratio.

3.12.6 Editing Paths

_A

A Path consists of Lines, Arcs and Curves. A filled path has always got a closed
outline. An unfilled path can be open. A path can consist of several parts that don’t
have to be connected with each other (Sub Paths). After you have filled a Path all the
independent parts are closed. A Path is filled Even-Odd or EOR (exclusively or) that
means that areas outside of the outline are left blank.
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Create/Join

You can create a Path by joining multiple graphic objects. You can generate a path
out of Lines, Arcs, Curves and Paths that exist already. Use the Join item in the Edit
menu to create a path (EditrJoin).

Additionally you can create a path from other objects. For example you can build the
contour of an object (see section 3.13), or by flattening a text (Kapitel 3.3.4).

Selecting

Click on the path to select it. All points of the selected path are marked with a knob.
When a path is open and not filled the selected endpoint is displayed bigger than the
others.

Splitting

You can split a path with the Split command from the Edit menu (Edit> Split).

Punch

You can punch a filled path from another filled path with the Punch command from
the Edit menu (Edit> Punch/Unite). The paths you want to punch must have different
colors. The paths on top are punched from the paths covered.
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Unite

You can unite multiple filled paths with the Split command in the Edit menu (Edit >
Punch/Unite). The paths you want to unite must have equal fill color (the stroked
border had been added after uniting the paths!).

Moving

You can move the path by clicking on the border of the path and keeping the mouse-
button pressed as you move. If you want to grab a corner point of the path to move it
(for example to attach it to other objects or snap it to the grid), the path must not be
selected before starting the move.

Moving points within the Path

The selected points of a Path can be moved with the mouse. Just press the mouse
button on a knob of the Path and drag it to the new position.

Hint:

* When you keep the right Alt key pressed the path or a point is moved only in
one direction.
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3.12.7 Editing Polylines

A Polyline is very similar to a path with the difference that a polyline contains lines
only. A Polyline can be open or closed.

The advantage of using a polyline is, that it is managed very efficiently which makes
the Polyline faster and the size of your project much smaller.

Create

v

Selecting

To create a polyline, you have to activate the Polyline mode in the Tool-Bar.

A Polyline can be selected by clicking on it. The corner points of the Polyline will
be marked by knobs.

Moving

You can move the polyline by clicking on it and moving it while you keep the mouse
button pressed. If you want to move the Polyline by grabbing it at a corner point be
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sure that the Polyline is not selected. This way you can attach the Polyline to other
objects or snap it to the grid with the grabbed point.

Moving corner points

The selected points of a Polyline can be moved with the mouse. Just press the mouse
button on a knob of the Polyline and drag it to the new position.

3.12.8 Editing Text

Cenon
=Modular Graphics«

and Manufacturing
Software

Create

Text
Select the text button from the Tool-Bar.

1. The first mouse click sets the position of the text.

2. Now you can start writing the text.

Selecting

Click on the text to select it. The text-frame of the selected text is marked by 8 knobs.
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Moving

Click on the text-frame to move it. You can move it by keeping the mouse-button
pressed (drag).

Resizing the text box

You can change the size of the text-box by dragging one of the eight buttons to a new
position.

Editing

You can edit the text with a double-click within the text-frame in the usual way.
When the text-mode is active you only have to click once to edit the text.
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When you edit text a ruler appears on top of the Graphic-Window. In the ruler you
can set the text attributes of the selected part of the text (Alignment, line distance,
Tabulators).

You can change the font by using the Font-Panel. You can get it with the menu item
Format > Font > Font-Panel.

You can change the color of selected parts of the text by using the Color-Panel. You
can get it with the menu item Tools > Colors.

Tips:

* When you keep the Alt-key pressed the moving of the text-box is only carried
out in one direction.
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3.12.9 Editing Text on Paths

Creating

1. Select a text and a path element (line, arc, curve)

2. Now select the menu item Format > Text > Bind To Path

Splitting

To split a Textpath into its components, select the menu entry Edit> Split.

Selecting

Click on the path of the Textpath to select it. The path element of the selected
Textpath is marked by knobs.

Moving

You move a textpath the same way as you would move the path it is bind to. See the
description of the used path element (Line, Polyline, Arc, Curve) to read more about
how to move the Textpath.
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Editing

You can edit the text of the Textpath with a double-click on the path element. This
brings the text in a unrotated position, so you can easily edit it. When you’re done
with editing the text, press on the Arrow in the Tool-Bar.

3.12.10 Editing Groups

A group consists of several objects grouped together in one object.

Creating

You can create a Group by grouping several selected objects. You can group almost
everything. Use the Group item in the Edit menu to create a group (Edit> Group).

Ungroup

You can split a group with the Ungroup command in the Edit menu (Edit > Ungroup).

Selecting

Click on a group to select it. The buttons of all united graphic objects are displayed.

Hint:

* When you keep the Alt-key pressed the group can only be moved in one direc-
tion.

3.12.11 Editing Marks

In a CAM application a mark is usually used to mark drillings. But that’s not the
only way to use a mark. Basically a mark is a single point in your document.
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Creating

To create a marking you have to switch in the marking-mode. You set a
marking with a mouse-click.

Selecting

Click on the mark to select it. The center of the selected marking is marked with a
knob and its position is displayed in the inspector.

Hints:

* When you keep the right Alt key pressed the moving is only carried out in one
direction.

3.12.12 Editing Threads

Usually a thread is used to cut a thread in an already existing hole or cylinder. You
can create inside and outside threads.

Creating

To create a thread you have to switch in the thread-mode. You set a thread
with a mouse-click.

1. Decide whether you want to create an inside or outside thread. Create a hole
for an inside thread, or a cylinder for an outside thread. The dimensions of the
hole depend on the data of the thread cutter you use. See the data sheet of the
tool.
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2. In the Layer-Panel create a layer for the thread.

3. In the Layer-Panel set the tool-radius correction of the layer according to the
kind of thread you need: Inside correction = inside thread, Outside correction
= outside thread. (see section ??)

4. In the Layer-Panel assign a thread cutter to the layer (see section 2?).

5. In the Tool-Bar change to the thread-mode (see section 3.4), then set the thread
with a click to the desired position.

6. Set the nominal diameter of the thread in the Thread-Inspector (see section 3.6.3).
The nominal diameter is the diameter the screw diameter got its name from.
For example: M6 for a 6 mm screw and thread. You have to enter 6 (if the unit
of Cenon is set to mm).

Selecting

Click on the thread to select it. The center of the selected thread is marked with a
knob and its position is displayed in the inspector.

Hints:

* When you keep the right Alt key pressed the moving is only carried out in one
direction.

3.13 Konturen erzeugen

With the menu Editr>’Build Contour’, you can create the contour of a selected
graphic object. In the Contour-Panel which appears, you can set the distance of
the contour to the graphic object. The result will be a Path , which resembles the
contour of the object.
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& M Contour

Replace Source v

Raster Algorithm [_|

Distance: 1 " mm &=

In this panel you can enter the distance of the new contour to the previous object-
contour. The distance can be negative. That means the new contour is inside the
object contour. When you click on Set every selected object is transformed into
a Path that is bigger or smaller than the original object (depending on the chosen
distance). You can set the unit of measurement for the distance.

When the distance is too big this might create unwanted overlappings. You can
remove them by hand.

Replace Original ~ If you check the switch, the original will stay, otherwise it will
be replaced by it’s contour.

Raster Algorithm  Instead of the (more precise) vector algorithm, the tolerant raster
algorithm is used.

You also can build a contour of an image. This would be called a vectorization.

3.14 Vectorizing

Via the menu item Tools > Vectorize, you can turn raster images into vector graphics.
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™ ™ Image Vectorization

Replace Image Cl

Fill Result ]
| Curves [ ;.5
Tolerance: 10 """'f.';:'.i;lnuu....,
Vectorize
Replace Image If this switch is active, the original image will be replaced.

Otherwise the original image with stay alive.

Fill Results This switch will fill the generated vecotr path.

Curves With this Pop-Up menu you can chose if you want to create
Curves or Lines.

Tolerance Curves will be created with a certain tolerance that can be set
here. The smaller the tolerance, the more curves you will get.

To achieve good results, the image should be monochrome and available in high
enough resolution.
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3.15 Color Separation

To prepare your document for exposition and pre-press, you have to separate the
document into the four basic colors cyan, magenta, yellow, and black. Therefor four
films respective files will be generated.
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The selected paper size (here AS landscape) will be surrounded by crop marks and
descriptive text. These make it possible to identify the filmes and precisely stack
together the four separate colors for printing.

The color separation of Cenon is integrated into the Print-Panel. Use the menu
Print... to open the Panel.

_ Output Type
) Composite
{®) Separations

This buttons allow to activate the color separation process.

€ 3
R A To generate files click on the save button of the Print-Panel. A file

selection panel will appear where you can set the destination and name of the files to
write. The files will be written with the name extended by some characters specifying
the color (_c=cyan, _m=magenta, _y=yellow, _k=Dblack).

@ Use the Print button to send the separated colors directly to a printer or
type setter.

Note: To get the desired page layout on color separation, be sure to set your working
area to the same size as the page layout (see section 3.3.4).

3.16 Multi Page Documents

Cenon allows the creation of multi page documents. All you have to do is tell Cenon
to use a layer as page. This can be done with the Layer-Details Panel (Section 3.7).



146 CHAPTER 3. REFERENCE PART - THE FUNCTIONS OF CENON

The behaviour of pages is different to that of layers. Only one page can be visible at
once, and the template layers holding the definition of page numbers, are displayed.

Printing automatically turns to multi page, if at least one layer of the type ’Page’ is
inside the document.

3.16.1 Procedure

1. Inside the Layer Inspector create a layer for each page. After this, change these
layers to pages with the Layer-Details (double click).
Layer-Datails: Section 3.7.

2. Create the Template layers according to your needs. Alternatively, you can
load and "recycle" predefined documents.

3.16.2 Templates

On a template layer variable elements are stored, which are displayed on pages ac-
cording to their purpose. You have the choice between three kinds of template lay-
ers:

Template The elements on this template, are used on all pages. Here you
can define a page numbering, which is displayed on even as well
as odd pages, for example.

Template Odd This template provides elements used on odd pages only. For
example a page number which should sit at the outside of pages.

Template Even  This template contains variable elements for even pages.

The elements of templates:

The elements of templates are created as text objects (Section 3.12.8) with appropri-
ate wildcards. Tehse wildcards will be replaced by the page numer etc.
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#PAGENUM# This label will be replaced by the page number.
Example: "Page #PAGENUM#"

#PAGECNT# This label will be replaced by the number of pages,
ex. "Page 2 of 10".
Example: "Page #PAGENUM# of #PAGECNT#"

#DATE_%Y-%m-%d %H:%M# This wildcard will be replaced by the current date.
The format of the date can be configured. The
example will be displayed as 2012-06-12 13:55.

%Y | year (2012)

%m | month as number (06 = June)

%d | day as number (12)

%a | day shortcut (Tue)

90H | hour (13)

%M | minutes (55)

%S | seconds (00)

%Z | time zone description (Europe/Berlin)

%z | time zone in hours (+0100)
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Chapter 4

Device Configuration

4.1 General Information

The configuration files of Cenon are ASCII files containing all the information needed
for the definition of devices and import formats.

This section will describe how to configure Cenon for the different "dialects" of
Gerber, HPGL as well as for your own XYZ-units and controller. Although Cenon
comes with a number of predefines configuration files (*.dev), there is a chance that
the commands of one or the other program is not understood properly or that there
is no 100% matching configuration file available for your controller or device. Un-
fortunately, there are slight differences in the command set of the different programs
and controllers.

4.1.1 Creating your own configuration files

In case you do not find a suitable configuration file for you purpose in one of the
device directories (HPGL, DXF, xyz etc.), you can alter an existing file.

e Start a text editor.

149
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Load an already existing configuration file (extension: *.dev). Only load files
from the appropriate directory and save them in the same directory after mod-
ification. This is very important, because Cenon uses the directory name for
accessing the right file format. The setup directory names, for these reasons,
should not be changed. Therefore, a Gerber configuration file should only be
placed in the directory Gerber, etc.

To avoid duplication of work you should load a configuration file which matches
the command set of your computer the most. You can change the configuration
file to your needs using the information provided in the output device manual.

After changing all necessary entries you have to save the file (to the same
directory under a new name) and quit the text editor.

Load from within Cenon the newly created file (Menu: Info > Preferences) and
you are ready to start.

4.1.2 Important Notes

The comments before the number sign (here: controller) are not important for
the program (comment here: device name). These can be changed to your
needs or even deleted. Cenon is recognizing only the characters from the num-
ber sign to the end of the line (here: "CNC750"). Example:

controller #CNC “‘CNC750’’

The entries are not permitted to exceed more than one line.

The order of the entries is not important, unless there are several entries with
the same #-code. You also can delete an entry if it is not necessary.

Within a command line you can add after a backslash () certain sequences to
the code. You could for example, write in a new line each single command in
the output file:
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\n Neue Zeile (Zeilenvorschub)

\e Escape-Sequenz

\r Carriage Return (Wagenriicklauf)
\" Anfiihrungszeichen

* If you have to leave space for variable parameters, which will be provided by
Cenon. This is done with a percent sign (%) followed by a letter:

Yot will accept a floating value (with decimal values entries). The
output format can be regulated with these entries. Examples:
%.0f  ->1
%.2f ->1.00
%?2.2f ->01.00
%2t ->01

%d is describing decimal integers

Jox is describing hexadecimal values

%ld is describing decimal long integers

Yoe is describing numbers with exponents

* Transmitted commands are always in quoted and also contain the appropriate
variable (e.g. pen selection for a HPGL-Plotter:

select pen #PEN "SPyd;"

e Parameter providing information to Cenon (e.g. number of pens for HPGL-
plotter or the size of the working area) are not quoted:

number of pens #NPN 8

* If several values are passed on to the program in one command line, these
values have to be separated by at least one space (e.g. maximum working area
of a unit):

X Y Z-maximum range (mm) #SIZ 380 235 63
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4.2 Gerber-Import/ Export

4.2.1 General Information

For importing Gerber-files there is besides the differences in the command set also
the problem of choosing the appropriate aperture table for the output. This glitch is
solved in the new extended Gerber format. But first some general information about
Gerber-Photo-plotter.

The Gerber-file-format is well know and has been in use for a long time to create
high quality film layouts with photo-plotters. More and more this is done with laser
plotter which can interpret the PostScript format. But to better understand the Gerber
file format let us go back to the times, when the computer aided printed circuit board
development was in its early stages. Earlier plotters with very large casings were
used, which used a regular bulb for film exposure. To achieve different conductor
path widths and different shapes of soldering points, the plotters were equipped with
a shutter unit with different aperture sizes. Depending which aperture was placed in
front of the light bulb, different conductor path widths and soldering points could be
simulated.

A so called D-code was used to tell the photo plotter which aperture to use. Each D-
code is representing a particular aperture on the shutter unit. Because these shutter
units were restricted in size, only a limited number of apertures were available and
therefore, only a limited number of D-code possibilities were available. For modern
units, this problem does not exist, because mechanical apertures are replaced by
apertures simulated electronically.

Each time a printed circuit board is exported by your CAD-application through a
Gerber file, a file with all the circuit board data will be created. This file contains
the necessary D-code information. Therefore, for each path the appropriate aperture
indicates the width of the conductor path and the style of the soldering point. All
this information is stored in the aperture table. Because your PCB manufacturer
uses this table for setting up his photoplot unit for producing the board he needs this
information. While importing the file for engraving the insulating path to the Cenon
application, Cenon is actually using this file to simulate the photo plotter.
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Some CAD applications have the drawback of using dotted lines for the representa-
tion of soldering point instead of using the appropriate flash command. This results
in very large Gerber files which result in extremely long calculation times and unsat-
isfactory results. Try in these case a PostScript output or change the application.

Most of these problems are solved with the new extended Gerber format (RS274X).

4.2.2 Export of Gerber files

The export of Gerber files is not critical. Cenon always writes the extended Gerber
format, so no paramaters have to be set.

4.2.3 Import of Gerber files

For importing Extended Gerber files just click on the file.

For importing standard Gerber files you need, besides the Gerber file an Aperture
table file.

» Aperture-Tabelle (Extension *.tab)

The folder Devices/gerber contains a default aperture table with the name of the .dev
file. While importing the Gerber file this table will automatically be loaded, unless
there is a specific aperture table with the specific project name in the project folder.
In this case, the appropriate project aperture table has priority and will be loaded.

Unfortunately, there is no standardization for creating an aperture table. Therefore,
you have to prepare the table of your CAD-system usually with a text editor so that
Cenon can use it.

To make the task of adjusting the aperture table or adopting your CAD application
format easier, we will explain the single entries in the following sections, so that you
can make the necessary changes.
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4.2.4 Commands in the configuration file

device name #DEV "Gerber"

This describes the name of the unit. The name can be up to 20 characters long and
the name selection is your choice. At appropriate places within Cenon this name will
be used for display.

resolution in points/inch #RES 1000
Preset resolution for the output of the file in points per inch.

tool #ITO "D"
tool #IT1 "DX"

These two code segments contain code to select the appropriate aperture. The second
value is optional.

X #IXp "X"
Y #IYP "Y"

Code for a x- or y coordinate.

I #IIP "I"
#IJp "J"

Code for the relative translation of a x- or y-coordinate.

draw #IDR "D1"
Code to switch on the light (comparable to the pendown command for plotter) with
which the film in Gerber plotters can be exposed. In contrast to the flash command,

the light stays on during the whole movement of the photo plotters and can be used
for conductor paths.
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move #IMO "D2"

Movement to new position with the light switch off (comparable to pen-up).

flash #IFS "D3"

Flash light for marking a soldering point.

circle cw #ICI "G75*xG0O2"

Command for drawing a circle clockwise.

arc #IAR "G75"

Command for drawing an arc (-segment) clockwise.

terminator #ITR "x"

Termination sign for ending the command sequence.

absolute #ABS "G9O"
relative #REL "GO1"

The coordinates can be forwarded either as absolute (in reference to a fixed origin)
or relative (in reference to the last position) values.
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4.2.5 The Aperture Table

This file is only need for standard Gerber. If you use the Extended Gerber format
(RS274X) you can skip this section.

tool, type (L=trace/line, P=flash/pad, A=both),
width, height (mill), form (C=circle, R=rectangle)

This is the decription at the beginning of the aperture table. It is important to follow
the order in which the entries are placed in each line:

* The D-code (aperture number) of a specific tool is placed directly after #DCD

This is followed by a character, describing the tool type (aperture). As char-
acters are possible: L for lines (trace/line), P for point (flash/pad) and A for
both.

Next entry is the tool width in mil (1/1000 inch).

Thereafter, the entry for height, also in mill.

Last, the shape has to be entered. As possibilities you have C for circle or R
for rectangle.

The complete aperture table has to be build in this way, so that Cenon can use the
file. If your CAD application is able to create the aperture files in this way, you will
have it very easy. In this case you only have to name the file and assure that the file
has the extension *.tab. If this file will be used as standard aperture table, save it in
the Devices/Gerber folder with the name Gerber.tab. If it is used for a certain project,
save it in the appropriate folder with the filename and the extension *.tab.

After saving the file you can load it when needed. If for some reasons your CAD-
program is not able to produce such a matching file you are required to make changes
by hand. The following two lines give you an example of part of a manually altered
aperture file table:

line 0.1 mm #DCD "D10x" L 4 4 C
pad 0.5 #DCD "D39x" P 20 20 C
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4.3 DXF-Import/ Export

4.3.1 General Information on DXF

DXF is an abbreviation for "Drawing Exchange Format" and became mostly known
through the application AutoCAD. Not only AutoCAD, but other CAD applications
use this file format mainly to exchange technical drawings. Because DXF-files can
be imported from Cenon directly (in contrary to HPGL-files) we will not elaborate
on this format and would rather guide you to the DXF specifications for download
from http://www.autodesk. com.

4.3.2 Export of DXF-Data

For output of DXF you can decide whether to flatten text into lower graphic elements.
Use the preferences panel for Export (see section 3.1.3) to toggle this option.

4.3.3 Import of DXF-Data

For the DXF import there isn’t much to adjust. Important is the correct setting of the
measurement unit for the file which you want to import. You can set this resolution
in the Import part of the Preferences-Panel.

When writing a DXF file from a CAD application, be sure to set the drawing extends
so that your entire drawing is inside.

4.3.4 List of supported DXF syntax

Interpreted Table Entries:

* BLOCK

* LAYER


http://www.autodesk.com
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Incomplete list of implemented Graphic Elements:

4.4

ARC

INSERT

LINE
LWPOLYLINE
MTEXT
POLYLINE
SOLID

SPLINE (>=4.1)
TEXT

VERTEX

3DLINE, 3DFACE

HPGL-Import / Export

4.4.1 General Information

The HPGL- format is an established and well known language to control pen plotters
of any kind. The quality and the speed of the import process is depending on the file
created by your program. If for example, every line in file is created with one line
thickness, a thick line has to be created from several thin lines during the converting
process. We may experience the same problem drawing a circle. In this case a circle
will be composed from many smaller line pieces, which is a very time consuming
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process and will not provide best results. In general it is not advisable to use HPGL
files for calculating insulation paths.

HPGL is not the best choice for the calculation of outlines or filled areas. Filled
areas are represented in HPGL by many parallel lines. In these cases Cenon will have
difficulties calculating the milling path. You should export HPGL-files therefore in
the most simplest way (without filled areas, overlapping areas or thick lines etc.).

4.4.2 Export of HPGL files

The export generates a standard HPGL file, without the option to configure derivates.

4.4.3 Import of HPGL files

The import is using the entries provided by the configuration file.

4.4.4 Commands in the configuration file

device name #DEV "HP 7550"
This describes the name of the unit used and serves only information purposes.
resolution in points/inch #RES 1021

This value indicates the plotter selected resolution of the output file in points per
inch.

number of pens #NPN 8

Describes the number of pens, which will be used for the output file.
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1. pen width (unit: 1/1000 mm) #PWI 250

This describes the pen width in units of 1/1000. For a thickness of 0.25mm a value
of #PWI 250 has to be entered. For each pen width there is a separate line. If for
example the field number has an entry of 8 you have to have eight different entries
for the different pens. This is true even when the width of all eight pens is the same.
The first entry always stands for the first pen.

1. pen color (0 - 1000, rgb)  #PCO 1000 0 O

Plotters are in most cases equipped with several pens of different colors. Because the
color can not be entered directly with HPGL (in contrary to PostScript) the color in-
formation has to be determined indirectly by using different pen colors. For each pen
the color intensity for red, green and blue can be entered separately. From this color
information, color for each pen in the preview window of Cenon will be composed.

special characters in command strings:

\n linefeed

\e escape

\r carriage return

\”’ quotation marks

parameters will be inserted at %f (%d, %x, %1d, %e)

Please refer for the different parameter values to general information in section 4.1.2.
draw #DRW "PD"

Pen down command for drawing of lines etc.
pen #IPN "M

Selection of the actual pen
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move #MOV "PU"

This command is used for moving the pen to a certain position without drawing.

absolute #ABS "PA"
relative #REL "PR"

The coordinates can be forwarded to the output device either as absolute (in reference
to a fixed origin) or relative (in reference to the last position) values.

circle (radius) #ICI "CI"

Command for drawing a circle.

arc absolute (xm,ym,arc angle) #IAA "AA"

Command for drawing an arc in relation to the origin.

arc relative (xm,ym,arc angle) #IAR "AR"

Command for drawing an arc in relation to the last position of the pen.

terminating characters #ITR ";\n\r"

All possible characters for termininating a command sequence.
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4.5 PostScript-Import / Export

4.5.1 General Information to PostScript

PostScript is the industry standard of the publishing industry and the most popular
graphic format. In contrary to bitmap graphics, where images are composed of single
points, vector graphic images are composed from lines, circles, curves, rectangles,
etc., where closed paths can be filled with a color. This information will be sent
to a output device. There, the information will be converted to the printed image.
Since printing is done, after all, point by point, an interpreter will convert the vector
information to point information.

For Imagesetter, PostScript is the industry standard for a long time. All graphic
information is contained in one single file. Further external files to handle any output
are not necessary. If your application of choice is capable of creating PostScript
output files we strongly recommend to use this option. In this case it is not necessary
to enable special settings for importing PostScript files.

Depending on the system, PostScript is imported using varying interpreters. For
OpenStep the Display-PostScript of the system is used. For Apple and Linux, the
GhostScript interpreter has to be installed, which is usually the case on Linux sys-
tems, but not on Apple.

4.6 PDF-Import

The Portable Document Format is imported with the help of Ghostscript, provided
that you have installed GhostScript.
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4.7 DIN-Import

4.7.1 General Information

DIN files correspond to the DIN 66025 norm. Most of the drill data files can be
imported using this device.

Currently device configurations for the Excellon (excellon.dev), and the Sieb&Meyer
formats (sm1000.dev, sm3000.dev) are supplied. Additional configuration files can
be created.

Usually you want to modify the resolution entries only. This can be necessary, be-
cause some programs on the market use non standard resolutions for exporting files.

4.7.2 Commands in the configuration file

device name #DEV "Excellon 2000"

This describes the name of the unit. The name can be up to 20 characters long and
the name selection is your choice. At appropriate places within Cenon this name will
be used for display.

resolution in points/inch #RES 10000

Preset resolution for the output of the file in points per inch. Here 10000 points/inch.
This is what you usually want to change.

resolution (mm) in points/inch #RMM 25400

Preset resolution if set to mm (usually using M71). Here 25400 points/inch. This
information is used in the Excellon format only. The Sieb&Meyer format has a fixed
resolution.
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start #IST "%%3000"

This specifies a string to recognize the file format. In the exampe the Sieb&Meyer
3000 format is introduced.

parameter #IPA "$"

The supplied string introduces the parameter section of the Sieb&Meyer formats.

select tool #ITL "T"

The commant to select a tool (usually "T").

>

#IXp "X"
Y #IYP "Y"

The strings introducing the x-, and y-coordinate.
terminator #ITM "\n"
The string specifying the end of a command. In the example this is a usual line feed

(\n).

The device files contain additional commands which are not important or not ment
for modification.
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Appendix

5.1 Files and directories

5.1.1 Cenon program

The program file of Cenon is located in the application directory of your computer
system:

Apple: /Applications/Cenon.app
GNUstep: /usr/GNUstep/Local/Applications/Cenon.app
OpenStep: /LocalApps/Cenon.app

5.1.2 Library

In the Library path of Cenon you can find examples, projects and all the things which
are intended to be customized (configurations, data files, etc.). Cenon has a global
Library path shared between all users, which is not writable to a user and shouldn’t
be modified, and a User Library inside the home directory (here HOME) of the user.
You can place modified versions of files inside the User-Library folder.
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Apple: /Library/Application Support/Cenon
HOME/Library/Cenon

GNUstep: /usr/GNUstep/Local/Library/Cenon
HOME/GNUstep/Library/Cenon

OpenStep: /LocalLibrary/Cenon
HOME/Library/Cenon

Files can appear in both Library paths (the global library path and the home library
path). In this case the file in the home library path has priority. This allows a user to
modify a configuration file without changing the installation of Cenon.

In the following we describe the most important files and directories. All located in
the HOME-Library of Cenon:

| File / Folder | Description
Projects Your Cenon projects and examples
Examples Some examples of import formats

Devices/din/*.dev Configuration files for the drill data import
Devices/gerber/*.dev | Configuration files for the Gerber import
Devices/hpgl/*.dev | Configuration files for the HPGL import

Devices/xyz/*.dev The device configuration files

CAM Folder for special configurations
CAM/Jobs Your CAM projects and example projects
CAM/positions ASCII file holding the position memory
CAM/magazine ASCII file holding the tool magazine

Cenon provides two folders for projects (Projects and CAM-Jobs). There is no tech-
nical differences between the file format.

5.1.3 Cenon Modules

Cenon Moduls may be installed in various locations of the file system. The basic
location is dependant of the computer platform:



5.2. ERROR AND WARNING MESSAGES 167

Apple: /Library/Extensions/Cenon
HEIM/Library/Extensions/Cenon
HEIM/Library/Cenon

GNUstep: /usr/GNUstep/Local/Library/Bundles/Cenon
HEIM/GNUstep/Library/Bundles/Cenon
HEIM/GNUstep/Library/Cenon

OpenStep: /LocalLibrary/Bundles/Cenon
HEIM/Library/Bundles/Cenon
HEIM/Library/Cenon

5.2 Error and Warning Messages

* Select two objects for joining!

You have to select two objects to be able to join them and create a path object.

* Can’t create backup file. File not saved!
Check if you have write permission to the directory and the Cenon file you
tried to write.

* Could not open file FILENAME.

Check the read permissions on the file FILENAME, and on the directory it is
located in. You need read permissions on a file to open it. Another possibility
is that the file is corrupted or of a format Cenon is not capable to read. Check
for other messages in the Console.

* Could not open file FILENAME. Using Default.

Here Cenon tells you that it can’t read FILENAME, and uses default values
instead.



168

CHAPTER 5. APPENDIX

You have unsaved documents!

If you quit Cenon and have unsaved documents, this message appears to give
you a chance to save the files. You can review the unsaved files or quit anyway.
Can’t write file.

Check the write permissions on the directory you try to save in. Also check if
there already is a file which you are not allowed to overwrite.

FILENAME has changes. Save ?

This warning message appears if you try to close a window of a document
which hasn’t been saved yet. You have the choice to save the file or close it
anyway.

Do you want to revert to: FILENAME ?

This is a safety message giving you a chance to cancel your request to reload a
file and loose all your changes.

This Operation will force a recalculation of the graphic!

Cenon gives you a chance to cancel the operation or will start a recalculation.

This Operation can take a while!

You are warned that the following operation will take some time and you have
to wait until has been finished. This message does not appear in expert mode.

The contour will be calculated know! You may want to stop this operation
to calculate on a later time.

You are warned that the output tracks needs recalculation and you are given
a chance to calculate them on a later time. This message does not appear in
expert mode.

Layer LAYERNAME needs recalculation!

If you start the output and the output tracks of some layers are not calculated
yet, Cenon gives you a chance to cancel and take a look at the tracks before
you start output. Otherwise the output is calculated and executed directly.
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* No data to process!
You started the output without any data to process.

* Couldn’t locate tool name TOOLNAME in magazine! You may have re-
moved the tool since your last session.

You have tools assigned to a layer of your job which is not in the active mag-
azine. Check the magazines for the needed tool or select a new tool from the
pop up menu.

* Name ’'NAME’ allready in use!
If you add or rename a layer or position this message can appear. You should
rename the existing layer or choose a different name for the new one if possi-
ble.

* You need to install the Cenon Library!
Some Library files are missing. On OpenStep the Library of Cenon has an
extra package. Most likely you haven’t installed it.

* Only one layer of this kind allowed!
Cenon allows only one layer of the kinds: Fitting-Layer, Clipping-Layer, or
Levelling-Layer.

* Only one position for parking allowed!
This shouldn’t happen at all, but somhow you tried to add a second layer for
the parking positiong. This is not possible.

* Only a single rectangle allowed on leveling layer!
You created graphic objects on the leveling layer which are not allowed there.
Delete everything but a single rectangle.

* This Operation will remove the fill layer attached to the Pick Out!

The Pick-Out owns a second layer. If you leave the correction for a Pick-Out
this layer is removed.
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¢ Automatic adjust! Be sure to have placed the surface sensor correctly,
before pressing ’Start’.

If your machine allows automatic measuring of the tool offset, this message
gives you a chance to place the switch under the tool before it starts the opera-
tion.

* Do you really want to remove the current magazin?
A warning message telling you that you are about to remove an entire maga-
zine.

¢ Set Magazin: This operation will remove all tools from layers!

A warning message telling you that you have to assign a new tool to all your
layers, if you select a new magazine. You have the chance to cancel your
request.

* Stop work?

A warning message. It appears when you click on Stop while the output is
running. The Z axis is lifted and you have a chance to check things, before you
continue or stop the output.

¢ Graphic out of range!

Your graphic is located outside of the machine table. Be sure that the graphic
you want to process is completely inside the gray lines, representing the ma-
chine table. You have a chance to continue, but this can lead to an incomplete
output of your graphic.

* Please log in as root!

Licensing only works as user root.

More messages can appear in the Console window (or system log file). Especially
messages during calculation of the output path are listed there.

On Linux this file can be found in the menu of the Window Manager under Info >
System Console. On OpenStep it can be found in Tools> Console of the Workspace
Manager.
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5.3 Keyboard Commands

Editing, Selecting

The keys Alt, Shift, and Ctrl can be used in combination with the mouse. The mean-
ing of these combinations can be found in the description of each mouse action. See

section 3.12.

Menu keys:

The Command key (Cmd) on a PC is usually the left Alt-Key. On Apple the Com-

mand Key is the Apple or command key.

‘ Command ‘ Key word ‘ Description
Cmd-a all Select all
Cmd-A Area Show Working Area panel
Cmd-b bold Change selected text to bold
Cmd-B Batch Batch Production
Cmd-c copy Copy selected objects into buffer
Cmd-C Color Show Color-Panel
Cmd-d direction | Revert direction
Cmd-D Direction | Display directions of objects
Cmd-e equal Select equal objects
Cmd-F Form Show Transform-Panel
Cmd-g group Group selected objects
Cmd-G unGroup | Ungroup selected groups
Cmd-h hide Hide program
Cmd-i iltalic Change selected text to italic
Cmd-I Inspector | Show Inspector-Panel
Cmd-j join Join selected objects
Cmd-J unJoin Split joined objects (Path, Textpath, clipped Image)
Cmd-m mirror Mirror selected objects
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Cmd-M Moves Show output tracks

Cmd-n new Create new document

Cmd-o open Open (Load) document

Cmd-O Optimize | Optimize moves

Cmd-p print Print document

Cmd-P Page Show Page-Layout panel

Cmd-q quit Quit program

Cmd-r rotate Rotate selected objects by 90°

Cmd-R Ruler Toggle text ruler

Cmd-s save Save document

Cmd-S Save as Save document with new name

Cmd-t text Show Font-Panel

Cmd-T Tool Display tool diameter

Cmd-u unsave Revert to saved document

Cmd-U pUnch Punch selected objects

Cmd-v view Paste buffer into document

Cmd-w window | Close window

Cmd-x Cut selected objects into buffer

Cmd-z Undo

Cmd-Z Redo

Cmd-? ? Help

Cmd-1 Graphic-Inspector, when editing text: Copy ruler
Cmd-2 Width-Inspector, when editing text: Paste ruler
Cmd-3 Fill-Inspector, when editing text: Copy font
Cmd-4 Texttype-Inspector, when editing text: Paste font
Cmd-5 Layer-Inspector

Cmd-8 Bring to front

Cmd-( Bring one object further to the front

Cmd-9 Send to back

Cmd-) Send one object further to the back

Cmd-+ Toggle grid

Cmd-Shift-+ Show Grid Panel
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Cmd-< align text to the left
Cmd- center text
Cmd-> align text to the right

5.4 Frequently asked Questions

For an up-to-date version of the questions and answers visit the internet pages of
Cenon www.Cenon.info.

5.4.1 Import
The imported DXF graphic is displayed in a wrong size

Go to the preferences of Cenon to change the unit of the DXF import. The DXF
format has no defined unit, that’s why you have to tell the importing program the
unit of the file.

The size of imported fonts is not correct

You can tell the exporting program to flatten all text to a path.

If you are using HPGL or DXF, the cause is that no font information is inside the file,
so Cenon will use the default font.

If you are using PostScript, it is possible that the desired font is not installed on your
system. In the latter case you can install the font as Type 1 font. Ask the documenta-
tion of your computer system on how to do this or ask your system administrator for
help.
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Graphics which are generated using Freehand contain intersecting lines
In Freehand don’t use the output option Split Complex Paths. Otherwise Freehand

splits large paths into several smaller paths to limit the complexity of generated
PostScript files.

I can’t import HPGL files

The extension of HPGL files must be .hpgl, or .plt. The case (lower case) is important
on Unix systems!

5.4.2 Computer System

A double click on a file opens the file in the text editor and not in Cenon

Select the file in the File Viewer of the Workspace. Then go to the Tool Inspector

(Pop Up Menu Tools) of the Workspace (not Cenon), and move the Cenon symbol to
the left. Doing this you set Cenon as default application for the selected file type.

After a check for disks, no disk symbol appears in the shelf of the File Viewer

Disks are not displayed when their file name is missing or not appropriate. You can
find your Disk in the root directory (/).

Transport of Cenon files to DOS disks

Before you can copy a Cenon file to a DOS disk, you have to truncate the file ex-
tension (.cenon) to 3 characters (.cen). To use the file you have to change back the
extension to .cenon.

If possible, you should use Unix or Apple formatted disks to transport files.
The prefered way to transfer files is a LAN (Ethernet).
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Killing a process

If it happens that you have a process hanging around as a zombi, you can kill this
process.

On OpenStep go to the process list of the Workspace using the menus "Tools - Pro-
cesses’. If you have to kill Cenon, you must kill the output process (controller) too.

5.5 Glossary

"What does this mean?" is sometimes the question. This glossary should help you to
better understand technical terms and also give you a short explanation to important
terms from A (aperture table) to Z (Cenon). If more information is available in the
manual we will refer to the appropriate section of the manual.

Aperture Table An aperture table is necessary for importing Gerber
files. This file contains all the necessary D-code in-
formation to assign the aperture of the photo-plotter
(soldering point shape, sizes and conductor path thick-
ness) to the different layout elements of your CAD-
program. The aperture table used for export has to be
used for importing as well. The extended Gerber for-
mat doesn’t need an aperture table any more.

Blow Up Special kind of isolation tracks for producing PCB pro-
totypes. A blow up is used to increase the isolation
paths for easier soldering.

CNC-Controller The CNC controller is the link between your computer
unit and the engraving unit. The controller converts
the signals send by Cenon to signals of higher electri-
cal current, so that they are able to power the different
axes of the engraving unit.
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Configuration file

Conical

Inlay

Excellon Format

Extended Gerber

Gerber-Format

HPGL

Inner Contour
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In your configuration file (extension .dev) control com-
mands and other parameter for the output device are
defined or different commands of the different import
formats are translated for Cenon.Default A default is
an entry preset by an application.

Conical describes a shape which goes from wide to
narrow.

Inlays are a special case of cutting material, so that one
poarts fits exactly into another.

Excellon is a data format used by industrial drilling
machines for drilling holes in circuit boards. Many of
the CAD programs can export these data and enable
you to import all the drilling information. The format
is imported using the DIN import.

This is an improved Gerber format without the need
of a separated Aperture file. The format also allows
complex ground planes, which is very important for a
clean import of the data.

Gerber is a data format for exporting layout data. In
general, photo-plotter use this file format. Because
this file format is very common, most of the CAD-
programs are able to create files in this format.

This abbreviation is an acronym for "Hewlett Packard
Graphics Language" and is one of the well know and
mostly used command set for accessing pen plotter.

The inner contour is mainly used for calculating the
engraving path of filled areas. The appropriate tool is
labeled engraving tool.
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Isolationsgravur

Insulation engraving

Outer Contour

Outline-Algorithm

Pick-Out

PostScript

Project

Rub-Out
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Spezielle Art der Werkzeugradiuskorrektur zum Er-
stellen von Leiterplatten-Prototypen. Die Isolations-
gravur graviert die Isolationen um die Leiterbahnen.

Special kind of tool radius correction used to create
prototypes of printed circuit boards (PCBs). The insu-
lation is engraved around the tracks.

The calculation of the outer contour of components is
necessary, if the elements have to be cut-out totally
and the cut out should comply exactly with the layout
of the element. These cut-outs are normally done with
a milling tool.

The outline-algorithm is responsible for creating a con-
tour around graphic objects.

The pick out is a special method of creating output for
detailed engraving purposes. It is used with a conical
tool.

PostScript is a vector based page description, which is
mainly used in the DTP area. This format is normally
used to drive photo-type-setters to create inexpensive
film layouts.

A project in Cenon is your document file. It is saved
with the extension ’.cenon’. In CAM applications a
Cenon project can also be called a job.

Rub-Out area (especially PCB prototyping) indicates
areas were analog to the chemical process the conduc-
tion copper material is completely removed (important
for HF-applications). The actual tool diameter is used
for calculation of the appropriate path to completely
remove all the copper.
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Sieb & Meyer Sieb & Meyer ist a industrial drill data format. The
two Sieb & Meyer formats (1000 and 3000) can be
imported using the DIN import.

Spindle Also called HF- or SF-spindle. Using high frequent
three-phase current, extremely high revolutions per minute
(RPM) can be generated, to achieve a precise output
and a high feeding speed.

Cenon Universal graphics tool.
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