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2.6 Prototyping of Circuit Boards (PCB)

This tutorial describes the process of making a double sided circuit board. The steps
include export of all data from your PCB layout software, importing the data, en-
graving the insulations, drilling, cutting of the contour, etc.

When editing with Cenon, there are often several ways to achieve the same thing. In
this tutorial we will try to point out some of the different approaches, even if it makes
the tutorial a little longer.

2.6.1 Export

Before you can start, you have to export the data of both layers, the drill data, and
the contour of the board. The following table recommends export formats.

Data ‘ File Format ‘

Layers Gerber, EPS

Drill Data | Excellon, Sieb&Meyer
Contour Gerber, EPS, HPGL
Logo/Text | Gerber, EPS, HPGL

If possible, you can include the Contour Layer on the Soldering Layer. This will save
you one Import step.

2.6.2 First Steps

We start by opening the template file "PCB-Template.cenon” from the path *’/Li-
brary/Application Support/Cenon/CAM/Jobs/PCB”. You can use the Open-Panel (Menu:
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File> Open...), and click the Goto-button "Examples” to jump to the Cenon-Library.
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The Template file is a rather empty document. All you can see is two fitting pins.
However, almost all settings, you possibly need to make a circuit board are prepared
for you. Using the Template saves a lot of time.

Document Size

The Template Document provides a file size appropriate for boards of up to about
160x100 mm. You can change the Working Area in the Working-Area Panel to fit
your layout, Menu: “Format > Working Area ...” (See section 3.3.2).

™ 7 7 Working Area

Wicth [mm: | 200

Height [nm]: 150

Save a Copy

Now, before you do anything else, save your document with a new name !

From the Menu pick, File>Save As ... The Save-Panel appears and lets you chose a
location and Name for the file. We recommend to save files to your private Library-
or Documents folder "THOME/Documents/Cenon/Projects”.
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The Layers
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The PCB Template provides all layers you may need to assemble single- or double-
sided circuit boards. The following table gives an overview of the layers provided by

the Template.

Layer Purpose ‘ Source ‘ Tool

Contour The contour of the board. This layer is cut out Imported in EPS or | PCB
and has to provide a filled object (Path, Gerber, format, or Cutter
Rectangle, Circle). created in Cenon.

Soldering The Soldering Layer. This layer provides the Imported, usually Insulation
soldering data and calculates the insulation as Gerber file Graver
engraving.

Blow-Up Widens the insulation channels to make soldering | Calculated from Rub-Out
easier. The channels will only be widened where | data on Soldering Cutter
the distance allows widening. Layer

Rub-Out Areas wherein all surplus copper is removed. usually created in Rub-Out
This layer has to provide a closed shape covering | Cenon Cutter
part of the board. If you rub-out the entire board
no Blow-Up is needed.

Component | For double sided boards. This layer calculates Imported, usually Insulation
the insulation engraving. as Gerber file Graver

Blow-Up Widens the insulation channels. Calculated from Rub-Out

Component Layer Cutter

Rub-Out Areas wherein all surplus copper is removed. created in Cenon Rub-Out

Cutter

Fitting Pins | Fitting pins are needed for double-sided boards modified in Cenon Drill
only. They help to flip the board before
machining the Component Layer.

Additional layers can be added as you see fit, for example a layer to engrave a logo.
For Drill Data a new layer can be created automatically for each imported drill diam-

eter.

The tools will be explained in detail before we start machining.
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2.6.3 Import

After the data is prepared and the template document is loaded, we can now import
the various files to their layers.

This tutorial is using the Example files from the folder /Library/Application Sup-
port/Cenon/Examples/Demo2”. The board we are prototyping serves as the LED
board of a well-known CNC-Controller:

Import Soldering Layout

Please go to the CAM-Panel and pick the Tab ”Layer”, which brings you to the layer
management. Now select the Layer to which you want to import. In our case this
is the Soldering Layer. The Panel should look like below with the Soldering Layer
selected.
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When the layer is selected, go to the File-Menu and pick File > Import. The Import-
Panel (below) appears. Here you can chose the data file providing the soldering data.
In our example this is SL.ger, a Gerber file (RS 274 X).

In the Pop-Up Menu in the lower part of the Import-Panel, you can chose an import
location. We want to import to the ”Selected Layer”. That’s why we selected the
layer within the Layer-Panel.
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After you press the button ”Open”, the file will be imported to the selected layer, the
Soldering Layer.

Tip: There are other ways to import a file, for example, it is also possible to
move the Gerber-File from the Finder window into the Cenon document.
The file will then end up on the first visible (open eye #) and editable
(pencil #) layer (from the top of the layer list).

You can now move the imported file to a better location within the document. We
strongly recommend that you set a grid to make it easier to handle the imported data.
You can use the Grid-Panel (Menu Format> Grid> Set ...) to set a grid of lets say
1/10 Inch.
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Tip: If you group your layer (select all elements of the soldering layer and pick
Edit> Group from the Menu), you can grab the entire group at any desired
pad and move this pad to the grid. The entire group follows and is now
aligned to the grid !

After this step your Document should look something like the following:

MM % Tutorial.cenon

.

X: 850148 Y: 298685 W:4.2333 H: 230481 [mm (3] (@) - |[150% (4] 7]

.11. 1
@ ly) LED-Disploy vi.1
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Import and Alignment of Component Layer

The Component Layer is imported in the same way. In the Layer-Panel select the
Component Layer. Then open the Import-Panel and pick the data that should go to
the Component Layer.

This could end-up something like this:

The Component Layer might end up in a different position than the Soldering Layer.
Of course, we need both layers fit exactly on top of each other, which is easy to do.
You have several options:

1. Make sure all data of the Component Layer is grouped (Select all elements and
go to the Menu: Edit> Group).
Grab one Pad from the Component Layer and move the entire group on top of
the soldering layer. The group will snap (at the position of the pad you grabbed
it) to the grid and to elements of the soldering layer.

2. Before you use this way of aligning layers, make sure you are able to select
elements on non-editable layers. If you can’t, go to the Preferences (Menu:
Cenon > Preferences...). In the General Preferences check the switch ”Selec-
tion of non-editable layers”.

Now make sure neither the Soldering Layer nor the Component Layer is grouped
(Select the elements on each layer and pick Edit> Ungroup). Otherwise you
are not able to select a single element, which we have to do.

Make sure the Soldering Layer is not editable (broken pencil in Layer-Panel).
This means, the other layer will be moved later to fit on this one.
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On the Soldering Layer, select a pad that is also available on the Component
Layer. Select the same Pad on the Component Layer.

Open the Transform Panel from the Menu: Tools> Transform Panel ... and
click the Align Icon on top of the Transform Panel.

Make sure the ”Align Layers” Switch is active !

Now align Horicontally and Vertically by pressing the center Icons of both

Trows.
- " Transform
P))BBE3)
Horicontal
= E 2
Vertical
00 =0 e
Emign Layers

Now, both layers are perfectly aligned:

Tip: To avoid moving elements accidentally, we should protect the layer by
making it non-editable. If you click on the pencil icon of the layer, the
pencil will be broken and the layers can’t be edited any more.
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Import Drill Data

We can load drill data from several different formats, like Excellon, or Sieb&Meyer.
In most cases the format will be recognized automatically. Other formats based on
the ISO, DIN, G-Code standard should work as well.

Open the Import-Panel (Menu: File > Import) and pick your drill file. The file needs
the extension .drl to be displayed.

In the Pop-Up menu in the lower part of the Import-Panel select "New layer(s)”. This
will make sure we get a new layer for each tool (drill diameter). Every layer gets an
appropriate name including the diameter of the drill.
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Again it can happen that the drill data is not aligned with the rest of our layout. In
the same way as we have learned for the component layer, we can now align the drill
data of each drill-layer with the Soldering Layer.

The images show our drill data before and after alignment.
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And this is how the Layer-Panel looks like. There are 4 more layers with the drill
diameters.
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Import and Editing of Contour Data

We only have the contour left to do. Let’s try a different appraoch.
Make sure the Contour Layer (top layer in the layer list) is editable. In the Finder
window, locate the Contour file and drag it into your document. Voila:
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But ouch, there is a lot of stuff, we don’t need. All we need is the rectangle. Some
elements are not even in our working area, hmm. No big deal.

Select the group that has been imported by clicking on any element of the Contour
Layer.

Go to the menu and pick Edit> Ungroup (or Cmd-Shift-G). All ungrouped elements
stay selected.

Now, while holding the Shift key pressed, select the lines forming the contour (or
use Shift and the Drag-Select). This will deselect the elements of the contour. If you
hide all other layers (close the eye) this is easy to do.

All elements that are still selected can go. Simply press the Backspace key and these
elements are gone. All that’s left now is your contour elements.

Tip: If you accidentally lose the selection after the ungroup, you can always use
“Edit> Select All” to select all elements on visible (editable) layers, even
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elements outside the working area. You don’t have to adjust the size of the
working area to fit all elements. Make sure only elements on the layer(s)
you want are being selected.

What we have now should look something like the following. Our contour layer is
not aligned and consists of four single lines. What we need is a closed path or a
rectangle.

To turn the single elements into a Path, we first select all of them. We will show two
ways how to select all off the single elements.

1. While keeping the Shift key pressed, click every single line once until all are
selected (knobs are displayed). You can also use the Drag-Select.

2. Hide all layers except the Contour Layer and pick Edit> Select All.
Then go to the Menu and pick Edit> Join.

Tip: We can test if we did a good job by deselecting the Path (click beside
the Path) and then selecting it again. If something is not selected or the
Menu item Edit> Select All is still active, then we have to join the missing
elements too.

Next we align the contour layer by moving it to the grid or use the Transform-Panel
to center it.



2.6. PROTOTYPING OF CIRCUIT BOARDS (PCB) 73

-
.
]
1]
]
]

We are not done yet. We have to fill the contour to allow the tool radius compensation
to do it’s job.

Select the contour, go to the Inspector Panel and chose a basic Filling. Also make
sure that Stroke is off (stroke width = 0).

OO0 Path, OO0 Path

i

OF+i2 55 +ia

| Basic

kﬁ»-] | Not Stroked r’ﬁ“i

Color

Color

] e

Graduate Color __Width
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Advice:

It is better to include the Contour Layer in the data of the Soldering Layer
or Component Layer. Then you don’t have to import the Contour Layer
at all, simply move the elements from the Soldering Layer to the Contour
Layer. To move the elements to another layer, simply select what you
want to move, switch to the Layer-Panel and select the Contour Layer.
Now press the button "Move to Layer” - that’s it. Both layers have to be
editable.
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Creating a Rub-Out Area

There is nothing to import for a Rub-Out area. All we need is a closed graphics
object, like a Rectangle, Circle, or Path. Make sure the Rub-Out layer is the only
editable layer, when you start creating graphics.

Positioning the Fitting Bolts

The Fitting Bolts are needed for double-sided boards only. They make sure that you
can flip the board precicely.

Basically the fitting bolts can be located anywhere, even within the contour of the
layout.

A reasonable location is to the right and left of the contour.
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2.6.4 Pre-Manufacturing
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This part will explain the settings of the layers (manufacturing steps), assigning tools,

etc.

Most of the settings are preset in the template, some need to be set by yourself.
The table shows an overview of the layers, the strategy needed for their purpose, and
a suggestion for the appropriate tool.

Layer / Step | Strategy / Compensation ‘ Tool

Contour Outside tool radius compensation. For GRP/CRP Cutter or
double-sided boards, this layer should be Double-Tooth Cutter
mirrored, since it is the last thing to do after we depending on your board
flipped the board. material.

Soldering PCB Insulation. All electric potentials are Insulation engraving tool.
separated, even if tracks have to be tightened to
achieve this with the given tool.

Blow Up PCB Blow-Up. The insulation paths are widened. | Rub-Out Cutter or other
In narrow areas, the tool is going only as far as the | cylindrical tool
space allows.

Rub Out PCB Rub-Out. All surplus copper will be Rub-Out Cutter or other

removed. If you rub-out the entire board, there is
no need for a Blow-Up.

cyclindrical tool

Fitting Bolts | None Drill with the diameter of an
available fitting bolt (even the
shafts of broken tools can
serve as fitting bolts).

Bore None Drill

Logo/Text None or Inside compensation Insulation cutter or engraving

tool

The PCB Template has the default PCB magazine assigned, which contains tools
suitable for prototyping circuit boards.
For each layer you have to assign an appropriate tool. If you have to modify or
add new tools to the magazine, you can do this in the Magazine-Panel. The sec-
ond Tab in the CAM-Panel brings you to the Tool-Magazines (see section 3.4.3 and
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section 3.4.4).

Finally, below you can see how the fully assigned Layer-Panel gives you an overview
of all settings and assigned tools.
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e 0.1 Rub Out vhf RubOut 0.5 mm

& = 1.6 Fitting pins Drill 3.0 mm (m\'

e o= [ B 1.6 Bore 0.6 mm Drill 0.6 mm e

ww o= [ B 1.6 Bore 0.9 mm Drill 0.8 mm ( Show Details .. )

@~ | B 1.6 Bore 2.4mm Drill 2.4 mm e

@ o= [ B 1.6 Bore 3.5 mm Drill 3.5 mm T U r——
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Special settings of Layers

Contour Layer: If you make a double-sided board, it is important to mirror the
Contour-Layer. Select the Contour-Layer and click on the but-
ton "Show Details”. In the Layer-Details, the Switch ”Mirror”
has to be active. There is no visible change in the display, but
the output will be flipped (about the fitting markers) to fit the
component side.

| Outside 3 Fill
MIrrorE
Dip Depth: 1.6
Approach *: 0
Bore Diameter: You have to assign a drill from the magazine of appropriate
diameter.

You also have to set the dipping- or immersion depth of the
drills.
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Soldering Layer,

Component Layer:

Fitting Bolts:

Results

If you encounter issues with the calculation of your imported
data, you can switch to a second algorithm, which is more tol-
erant with bad data.

In the case of our Component Layer, for example, the fillings of
the ground areas are endless overlapping lines which criss-cross
all over the board. If we are in control, we can export better
data. Otherwise, go to the Project-Settings (see section 3.2.1),
select the CAM-Settings from the Pop-Up, and check the Switch
”Use Raster Algorithm”.

There is a second setting ”Deburring of PCB tracks”, which
will remove chips that could stay attached to the copper in tight
corners.

You can adjust the fitting bolts as you wish. They can even re-
side within the contour of your layout, if you don’t mind the
wholes.

A good location is just outside the contour, to the right and left
of the board.

The fitting pins are only needed for double-sided boards to al-
low flipping of the board precisely.

We are ready. Here is a display of the output tracks of the major layers.
You can also display the tool diameter for the display of your output. You can enable
this in the Menu: Display > Show Tool Diameter.
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2.6.5 Tools for Prototyping

79

In this section we will introduce the carbide-tools applied for prototyping of circuit

boards.

‘ Insulation Engraver

‘ Rub-Out Cutter

| Drill

| GRP/CRP Cutter

/)

LA

4

nE== =mewe T

This kind of tool is
applied to engrave the
insulation tracks.

The tip of this tool is
tapered from 0.05 to
0.7 mm with a tip an-
gle of 90°.

The tool is also well
suited for general en-
graving tasks.

This is a shortened
double tooth cutter,
which reduces the risc
of fracture. It is used
for the Blow-Up and
Rub-Out.

This tool is an all-
rounder and a perfect
engraving tool in gen-
eral. It is as well
suited for levelling the
run-out material, and
for cutting the contour
of low-quality circuit
boards.

Carbide-Drills are
used for all bore-holes

we have to drill.

These PCB
are available as

cutters

spiral-toothed or
diamond-toothed.

They are  made
for cutting highly
abrasive material
like fiber-reeinforced

circuit boards.

If you don’t use an automatic tool changer, make sure all tools are equipped with a
stop ring. The ring makes it a lot faster and easier to change and adjust the tools.

You can obtain these special tools in the vhf Tool Store. Tools will be shipped inter-
nationally within a few days.
http://www.vhf.biz/tools.
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Most tool parameters are pre-set in the PCB tool-magazine coming with Cenon. If
your spindle is not capable of the high revolution, you have to reduce the lowering

speed and feed accordingly.

Recommended tool parameters for drilling:

Diameter ‘ Revolution [rev/min] ‘ Lowering Speed [mm/s]

0.5 mm 60.000 25
0.6 mm 60.000 30
0.7 mm 55.000 35
0.8 mm 48.000 35
0.9 mm 42.000 35
1.0 mm 38.000 35
1.1 mm 35.000 35
1.2 mm 32.000 35
1.3 mm 29.000 35
1.4 mm 27.000 35
1.5 mm 25.000 35
1.6 mm 24.000 35
1.7 mm 22.000 30
1.8 mm 21.000 30
1.9 mm 20.000 30
2.0 mm 19.000 30
2.1 mm 18.000 25
2.2 mm 17.000 25
2.3 mm 17.000 25
2.4 mm 16.000 25
2.5 mm 15.000 25
2.6 mm 15.000 25
2.7 mm 15.000 25
2.8 mm 15.000 25
2.9 mm 15.000 25
3.0 mm 15.000 25
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2.6.6 Manufacturing

Now we are prepared to machine the board.

Levelling the machine

For perfect results of the insulation engraving it is crucial to have the machining area
leveled. There are several ways to achive this. We will just hint at two possible
options:

1. Use Leveling to measure the machining area and let the CNC-Controller com-
pensate inaccuracies in Z. Even better is to level the surface of the base mate-
rial. See section 3.5.3 for more information.

2. Use a cylindrical tool of sufficient diameter to level a good part of the machin-
ing area. Mount a running-out material (for example an acrylic board) to the
machine table. This material can now be leveled and used to attach the circuit
board. In Cenon you can simply create a rectangle with a standard filling. The
run-out material is needed anyway to protect the machine table from damage
while drilling or cutting.

Mounting the base material

First, we tape double-sided adhesive film (DX1) to the base material. We remove
the waxed protection-paper and make sure, we have no bubbles trapped under the
film. Then we remove the second protective-film and tape the board onto the run-out
material.

Another option is to use a vacuum table.

Start-Position

The first step is to move the machine to the starting position. The Start-Position is the
position on the machine reflecting the location of the cross-hairs in your document.
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In our example the Cross-Hairs are in the lower/left corner of the board.

In the image below we see the cross-hairs. Additionally we see the output displayed
with the effective tool diameter (Menu: Display > Show Tool Diameter). This lets
you anticipate pretty well the expected results after output

AO0 2% Tutorial.cenon

X: 103.5403 Y: 70.3791 W:-20.8903 H: 400403 | mm |§ |QH - || 200% :lu

You set the Start Position in the Control-Panel.

Ty CAM Panel

| Layer = Magazine | Control = Positions |

Start Position O
—
. N [ Adi Y| | Spindt
xfo 4 > ) oo
y b | Suction
Y: 50 4> (Home ) —
[z i
Move Height: 1 N 4 GL)
( Get ( SetPosition ) [OR]
() Selection
Tool: vhfisofrdser 0.2 mm
Offset 0 ( Start )

The X and Y positions are straight forward, simply move the machine with the help
of the arrow keys to reflect the position of the cross-hairs in your document window.
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Partly visible gray lines in the Graphics window also show the machine boundaries
relative to the Layout.

Each click on the arrow key will move the machine by 1/10 of the unit. If you keep
the Control-Key pressed while clicking, the machine moves a full unit.

Now enter a Move Height, that you wish to maintain, lets say 1 mm. This is the
Minimum Safe Altitue to fly.

Finally we have to exactly adjust the Z location.
First, we can roughly move Z down to a safe distance above the material.

1. Now, if you happen to have a surface sensor, use it.
Activate the Adjust Switch (to the left of the Z position) and move X and Y
above the base material (or contact plate).
Press the arrow for Z down.
The Z axis should lower until it touches the contact or circuit board, depending
on the kind of equipment. you use.

2. Here is the manual approach.
Activate the Adjustment Switch and move X and Y above the base material.
Lower Z with smallest (0.1 mm) steps until you can still see a little gap between
the tool and the surface.
Place a piece of thin paper between the tool and the surface of the board.
Lower Z until the paper can’t be moved any more. Stop here, that’s our Z-
position !

See section 3.4.5 for details.

To avoid engraving too deep, it is advisable to try with a Z position of about 1/10 or
2/10 mm higher first. Start engraving the Soldering Layer as a test. Stop the machine
after some engraving and decide wheather the insulation channels are right. Adjust
Z, if necessary in small steps of about 0.02 to 0.05 mm.

Order of Output

Layers are usually processed one by one. To select layers for machining open the eye
of the layer(s).
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The following list shows the order of output steps for a double-sided board:

L.

® N ok w

Engraving of the Soldering Layer

Engraving of the Blow-Up and Rub-Out of the Soldering-Layer
Drilling of the bore-diameters

Drilling of Fitting holes for fitting pins

Flip the board

Engraving of the Component Layer

Engraving of the Blow-Up and Rub-Out of the Component Layer

Cutting of the Contour Layer

The following list shows the order of output for a single sided board:

1.
2.
3.
4,

Engraving of the Soldering Layer
Engraving of the Blow-Up and Rub-Out of the Soldering-Layer
Drilling of the bore-diameters

Cutting of Contour Layer

For every tool change, the tool has to be adjusted. While this has to be exact for
engraving tools, the drills and cutters are easy to adjust and should fit well enough
by using distance rings on the tools.

Advice: To avoid a “running off” of the drills when dipping into the board, it is

advisable to use a run-in material, placed on top of the board. Pressboard
or resin board are good material. Make sure you drill deep enough into the
run-out material to get clean holes.

Advice: In order to achieve a high lowering speed for drilling and avoiding accel-

eration ramps within the drilling process, set the Move Height generously.



